[Gta04-owner] Not getting 3G network anymore

NeilBrown neilb at suse.de
Mon Dec 24 23:59:28 CET 2012


On Mon, 24 Dec 2012 11:20:23 +0000 Neil Jerram <neil at ossau.homelinux.net>
wrote:

> Hi all,
> 
> I guess there are several possible reasons for this, but worth
> announcing in case others see a similar thing.
> 
> In the last few days, my phone has stuck only to 2G connections -
> whereas previously it switched freely between 2G and 3G and in practice
> spent most of its time on 3G.
> 
> In QtMoko I can see this from the "G" in the top line, and also in
> House, Spanner, Call Networks, GSM, Select Operator, which now only
> lists networks with "(GSM)", whereas previously it had entries without
> that.
> 
> I've checked that my codebase doesn't accidentally have "AT_OPSYS=0,2",
> and it doesn't.
> 
> I suppose this could be because my phone has been blacklisted from my
> operator's 3G network - does that ever happen?  I'm not aware of having
> done anything to justify that, anyway.  Alternatively, I suppose it
> could be something in the modem, and hence worth flagging here.  I've
> tried a complete shutdown and taking out the battery for a minute or so,
> but it made no difference.

Have you tried explicitly requesting 3G with something like
   AT_OPSYS=3,2

??   I found that I was once stuck in 2G mode and no amount of power  cycle
and reset would get out of it, but issuing that command did.

NeilBrown
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 828 bytes
Desc: not available
URL: <http://lists.goldelico.com/pipermail/gta04-owner/attachments/20121225/436e6707/attachment.bin>


More information about the Gta04-owner mailing list