[Gta04-owner] Modem voice hardware routing

Radek Polak psonek2 at seznam.cz
Sat Aug 11 17:12:25 CEST 2012

On Saturday, August 11, 2012 04:18:02 PM you wrote:

> Thanks a lot! I got the patch integrated on top of the 3.2 Replicant
> kernel. With your alsa configuration, I was able to get sound from the
> other end to the GTA04 earpiece, with good quality and decent volume.
> Though, I didn't get any sound on the other end: the GTA04 apparently
> sends no sound. While trying to figure it out, I started the Android
> recording app, during the call, and sound immediately got sent to the
> other end, and it ended as soon as I closed the app. It worked exactly
> the same with arecord. So I guess the mic isn't "opened" there or
> something, when going with hw voice routing.
> I'll try to investigate this and look how different the code from 3.5 is
> from 3.2 (assuming that it works on your 3.5 kernel).

The patch is against 3.2 kernel (kernel for latest qtmoko release), but 
applies and works also against 3.5 kernel.

The symptom looks similar to what i had after this commit:

The commit was that i tried to raise mic volume, but with value 5 it stopped 
working. Maybe try to play with 'Analog Capture Volume'...

If you have all the code in git i could try it on my phone if needed.



More information about the Gta04-owner mailing list