[Gta04-owner] Modem closes serial line after active calls (sometimes)

Dr. H. Nikolaus Schaller hns at goldelico.com
Sat Apr 28 15:16:31 CEST 2012


Am 28.04.2012 um 14:44 schrieb Simon Busch:

> On 28.04.2012 12:06, Neil Jerram wrote:
>> Neil Jerram <neil at ossau.homelinux.net> writes:
>> 
>>> Simon Busch <morphis at gravedo.de> writes:
>>> 
>>>> Does anybody has seen this before or know whats causing the modem to
>>>> close the lines (modem is still up, lsusb lists it as normal)?
>>> 
>>> Yes, it's been extensively discussed already on this list.  I'll try to
>>> find the best references and follow up with those.
>> 
>> http://lists.goldelico.com/pipermail/gta04-owner/2012-February/001563.html
>> 
>> I think there have been some further discussions following that thread,
>> but I couldn't easily find links for those.
>> 
>> I believe Radek has put something in QtMoko to handle when this happens,
>> so perhaps he can provide a reference to that, and you can consider if a
>> similar solution will work for FSO/SHR.
> 
> Thank you very much Neil!
> 
> As far as I got the details from that thread there is no clean solution
> for the disconnecting modem just a workaround as Radek implemented it
> for qtmoko, right?

AFAIK: yes.

The workaround appears to work, so the urgency to find a clean solution
has been reduced.

As a side note: almost all systems have workarounds inside - but you
can't see them if they have closed source...

> 
> regards,
> Simon
> 
> -- 
> Simon Busch - http://mm.gravedo.de/blog/
> _______________________________________________
> Gta04-owner mailing list
> Gta04-owner at goldelico.com
> http://lists.goldelico.com/mailman/listinfo/gta04-owner



More information about the Gta04-owner mailing list