[Gta04-owner] 3.2-rc6-gta04 - another week, another rc.

NeilBrown neilb at suse.de
Mon Dec 19 01:14:52 CET 2011


Hi,
 git://neil.brown.name/gta04 merge

is now based on 3.2-rc6.

Other changes:

 - power management for wifi is now fully automatic.
   When you 'up' the interface the power is turned on.
   Wnen you 'down' it, the regulator is turned off.
 - power for bluetooth and GPS antenna are now controlled
   through rfkill.  Use
     rfkill list
   to see the devices.  You might need to "apt-get install rfkill" 
   first.
   The bluetooth and GPS start out not blocked, so power is on.
   So "rfkill block all" to save some power.

   We really want them to start out with power off though.
   I think the best way to achieve this is to change uboot to
   *not* turn those regulators on.  It should probably leave as
   many regulators off as possible.

   Note that rfkill doesn't control the GPS on/off toggle yet.  You still
   need to echo 0 and 1 out to the magic gpio.  That is to-be-done.

 - The "slab corruption" messages that Neil Jerram mentioned are gone.
   It was a set-after-free bug.

 - I've compiled in the SOUND card code but I don't think anything
   useful works yet.  e.g.

gta04:~# cat /proc/asound/cards
 0 [Dummy          ]: Dummy - Dummy
                      Dummy 1
 1 [Loopback       ]: Loopback - Loopback
                      Loopback 1

   doesn't look promising.  There was a lot of forward-porting needed and 
   I haven't finished the fm received yet (so it is commented out) but the
   rest I have probably broken.

 - If you have an 'OTG' usb cable you can try plugging in a thumb drive.  It
   probably won't work though as the thumb drives I've tried say they need
   200mA and the OTG port can only provide 100mA.  If you use a powered hub
   it might work.  Or find a thumb drive that claims it only needs 100mA.

       sudo lsusb -v | grep -E '(^Bus|MaxPower)'

 - I haven't done much more with suspend - just replaced a fairly horrible
   hack with a much simpler solution (setting a flag).  This is to fix the
   problem were it tried to talk I2C to the power management chip very late
   in suspend after interrupts had been disabled.

   However I've been doing a fair bit of research and think I know what to do
   to make progress with suspend.


Merry Christmas and/or Seasons Greetings and/or Happy New Year
(though I'll probably have another release before the (western) New Year)

NeilBrown
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 828 bytes
Desc: not available
URL: <http://lists.goldelico.com/pipermail/gta04-owner/attachments/20111219/28c5ae54/attachment.bin>


More information about the Gta04-owner mailing list