[Gta04-owner] 3.2-rc5-gta04 - suspend is getting closer.

NeilBrown neilb at suse.de
Sat Dec 10 21:47:01 CET 2011

My gta04 kernel tree:

  git://neil.brown.name/gta04 merge


is now based on 3.2-rc5.

Other changes:
 - problems reading the bq27000 battery monitor have been resolved.
   The HDQ interrupt handler sometimes sees '0' when it reads the register
   that indicates what caused the interrupt.  This should be impossible.
   When it happens, I got the code to work out what probably happened and
   assume that.  Now it works much more reliably.

 - The battery charger is more reliable now.
   - it really charges the backup battery now.
   - it works from legacy usb chargers (like the openmoko charger) which
     ground the ID pin through a resistor rather than shorting the D lines.
   - it is enabled as early as possible, even if no usb-gadget module is

 - Wifi really works now.  In the previous release it still needed a bit of
   tweaking to make it wake up.
   There is something odd with the behaviour of this chip and I've been 
   discussing with upstream developers to try to understand it but still have
   a way to go.  But at least I can make it work.
   You shouldn't need to drive the reset line through /sys/class/gpio/...
   any more - just the card-detect line.  See script below.

 - The 'rtc' problem I was having before is resolved.

 - power-off now works.  I made the red 'power' led default to 'on' to make
   it easier to test and observe this.  You can turn it off with
     echo 0  > /sys/class/leds/gta04:red:power/brightness

 - AUX button now produces KEY_PHONE just like the GTA02

 - suspend nearly works.
   In particular, "echo mem > /sys/power/state" seems to work.  It will then
   be woken up by pressing the power button or typing on the serial console
   (at least).  'rtc' doesn't wake it up (yet).
   However I'm not at all sure that it is really suspending as I don't think
   it is reducing power usage (I left it "suspended" for 7 hours and came back
   to a flat battery).
   So this is closer but there is some way to go yet.

 - the problem that caused power-off not to work in the previous release has
   been fixed upstream.  This is a little milestone as it is the first change
   that has gone upstream as a result of this effort :-)
 - the tca6507 driver for the LEDs has been included into Andrew Morton's -mm
   tree.  That might mean it will go in the 3.3 merge window, but I don't know
   for sure.

 - I'm sure I used to be able to remove the battery while the charger was
   plugged in and charging.  That doesn't work now.  I wonder if I broke

 - I really want suspend to work.  But that could soak up lots and lots of
 - rfkill devices for wifi, bluetooth, gps shouldn't be too hard once I
   understand regulators properly.
 - I still want an accelerometer driver.

Note that some important changes appear in the gta04a3_defconfig file,
particularly changes to the default kernel command line.  So if you want to
use your own .config, make sure to look at the defconfig for new stuff you
might need.


Script to enable wifi:
# VDD=2800000
echo 1 > /sys/class/gpio/gta04:wlan:cd/value
echo "$VDD" >/sys/devices/platform/reg-virt-consumer.4/max_microvolts
echo "$VDD" >/sys/devices/platform/reg-virt-consumer.4/min_microvolts
echo "normal" >/sys/devices/platform/reg-virt-consumer.4/mode
echo 0 > /sys/class/gpio/gta04:wlan:cd/value  # edge triggers interrupt.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 828 bytes
Desc: not available
URL: <http://lists.goldelico.com/pipermail/gta04-owner/attachments/20111211/ed77ac5e/attachment.bin>

More information about the Gta04-owner mailing list