[Gta04-owner] Error in pin layout of serial cable?

Jens Seidel jensseidel at users.sf.net
Fri Dec 9 00:39:51 CET 2011


Hi Christoph,

2011/12/8 Christoph Mair <christoph.mair at gmail.com>:
> On Wed, Dec 7, 2011 at 4:26 AM, Jens Seidel <jensseidel at users.sf.net> wrote:
>> Following http://projects.goldelico.com/p/gta04-main/page/SerialBoot/
>> I can access the device.
>> Booting from sd card fails nevertheless (tried 2 different cards, a
>> 512MB and a 8GB one).
>>
>> GTA04 # mmcinfo
>>
>> Card did not respond to voltage select!
>> Device: OMAP SD/MMC
>> Manufacturer ID: 0
>> OEM: 0
>> Name: Tran Speed: 0
>> Rd Block Len: 0
>> MMC version 0.0
>> High Capacity: No
>> Capacity: 0
>> Bus Width: 1-bit
>>
>> Any idea?
>
> Maybe the contact pins are misaligned somehow? Or they do not press
> firmly enough against the card?

Heh, you was right. After pressing firmly on the card holder it worked
and it even booted from the sd card. Now I get:

Device: OMAP SD/MMC
Manufacturer ID: 2
OEM: 544d
Name: SD08G
Tran Speed: 25000000
Rd Block Len: 512
SD version 2.0
High Capacity: Yes
Capacity: 7969177600
Bus Width: 4-bit

The first time I inserted the sd card a lot of power was required to
open the sd slot and I think I even lifted the plastic around the slot
from the motherboard. That's why I bent it a little bit to release it
so that it was as strong as in the GTA02. Will bend it again ...

Thanks,
Jens


More information about the Gta04-owner mailing list