<html><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space;">Hi,<div class=""><br class=""><blockquote type="cite" class="">Am 04.01.2019 um 07:05 schrieb Andreas Kemnade <<a href="mailto:andreas@kemnade.info" class="">andreas@kemnade.info</a>>:<br class=""><br class="">On Thu, 3 Jan 2019 23:08:11 +0100<br class="">"H. Nikolaus Schaller" <<a href="mailto:hns@goldelico.com" class="">hns@goldelico.com</a>> wrote:<br class=""><br class=""><blockquote type="cite" class="">Hi,<br class="">I have built a new debian image for Phosh (debootstrapped + letux-minimal + purism-sources-list + letux-phosh):<br class=""><br class=""><span class="Apple-tab-span" style="white-space:pre">        </span><a href="http://download.goldelico.com/letux-debian-rootfs/?C=M;O=D" class="">http://download.goldelico.com/letux-debian-rootfs/?C=M;O=D</a><br class=""><br class="">which can be installed (togehter with the letux-4.19.12 kernel) through<br class=""><br class=""><span class="Apple-tab-span" style="white-space:pre">     </span>makesd phosh<br class=""><br class="">or for a two-partition system like the Pyra or OpenPandora<br class=""><br class=""><span class="Apple-tab-span" style="white-space:pre">  </span>makesd pyra-4gb -r phosh<br class=""><br class="">(assuming the latest makesd: run "makesd -u" to be sure).<br class=""><br class="">There is now a user "purism" with default password "123456" which should also<br class="">be the PIN for the initial unlocking screen.<br class=""><br class="">This is of course not safe at all but good enough for initial experiments...<br class="">Phosh is still under heavy development and Debian/Buster is not yet stable anyways.<br class=""><br class="">Well, it boots but running phosh on the Pyra fails:<br class=""><br class="">root@letux:~# phosh<br class="">2018-12-21 18:54:53 - [rootston/config.c:370] Configured output Virtual-1 with mode 720x1440@0.000000<br class="">2018-12-21 18:54:53 - [rootston/config.c:370] Configured output X11-1 with mode 768x1024@0.000000<br class="">2018-12-21 18:54:53 - [backend/session/logind.c:363] Failed to get seat id: No data available<br class="">2018-12-21 18:54:53 - [backend/session/direct.c:159] Could not get current tty number: Inappropriate ioctl for device<br class="">2018-12-21 18:54:53 - [backend/session/session.c:76] Failed to load session backend<br class="">2018-12-21 18:54:53 - [backend/backend.c:250] Failed to start a DRM session<br class="">2018-12-21 18:54:53 - [rootston/main.c:26] could not start backend<br class="">root@letux:~# cat /etc/debian_version <br class="">buster/sid<br class="">root@letux:~# uname -a<br class="">Linux letux 4.19.12-letux+ #3090 SMP PREEMPT Mon Dec 24 13:47:00 CET 2018 armv7l GNU/Linux<br class="">root@letux:~# <br class=""><br class="">There is only a (properly rotated!) login: with blinking cursor shown on the display.<br class=""><br class="">Trying the same on GTA04A4 has exactly the same error messages but the display is even completely inactive.<br class=""><br class=""></blockquote>Does the phosh service start or are you seeing just gdm stuff?<br class="">The further is working for we, the latter not.<br class="">In my installation I had to do a manual<br class="">systemctl start phosh<br class=""></blockquote><div class=""><br class=""></div>Ah, good. It works :)<div class=""><br class=""></div><div class="">Takes approx 1 minute on GTA04 but then I get this screen:</div><div class=""><br class=""></div><div class=""><img apple-inline="yes" id="F350B82C-4106-4D49-99C3-0E3BFEC1F067" height="579" width="480" apple-width="yes" apple-height="yes" src="cid:C821A965-F419-4900-92C6-B4A7E92C61D9@fritz.box" class=""></div><div class=""><br class=""></div><div class="">Yeah!</div><div class=""><br class=""></div><div class="">Touch is not properly working as Mark already reported.</div><div class=""><br class=""></div><div class="">On the Pyra, "systemctl start phosh" makes the text framebuffer console</div><div class="">cursor stop blinking and "systemctl stop phosh" makes it blink again.</div><div class=""><br class=""></div><div class="">Xwayland is running but screen remains black. Maybe Xwayland can't</div><div class="">handle our TILER rotation properly.</div><div class=""><div class=""><br class=""><blockquote type="cite" class=""><br class="">since is was not configured to run at startup.<br class=""></blockquote><div class=""><br class=""></div>So we should add some autostart to the rootfs image.<br class=""></div></div><div class=""><br class=""></div><div class="">Maybe someone can provide a phosh.service file so that I can add it to</div><div class="">/etc/systemd/system/ in the letux-phosh.deb package.</div><div class=""><br class=""></div><div class="">BR and happy testing,</div><div class="">Nikolaus</div><div class=""><br class=""></div></div></body></html>