[Tinkerphones] about experimental Letux-Phosh (Purisms Phone's shell)

Sebastian Krzyszkowiak dos at dosowisko.net
Fri Jan 4 00:20:49 CET 2019


On 1/3/19, H. Nikolaus Schaller <hns at goldelico.com> wrote:
> Hi,
> I have built a new debian image for Phosh (debootstrapped + letux-minimal +
> purism-sources-list + letux-phosh):
>
> 	http://download.goldelico.com/letux-debian-rootfs/?C=M;O=D
>
> which can be installed (togehter with the letux-4.19.12 kernel) through
>
> 	makesd phosh
>
> or for a two-partition system like the Pyra or OpenPandora
>
> 	makesd pyra-4gb -r phosh
>
> (assuming the latest makesd: run "makesd -u" to be sure).
>
> There is now a user "purism" with default password "123456" which should
> also
> be the PIN for the initial unlocking screen.
>
> This is of course not safe at all but good enough for initial
> experiments...
> Phosh is still under heavy development and Debian/Buster is not yet stable
> anyways.
>
> Well, it boots but running phosh on the Pyra fails:
>
> root at letux:~# phosh
> 2018-12-21 18:54:53 - [rootston/config.c:370] Configured output Virtual-1
> with mode 720x1440 at 0.000000
> 2018-12-21 18:54:53 - [rootston/config.c:370] Configured output X11-1 with
> mode 768x1024 at 0.000000
> 2018-12-21 18:54:53 - [backend/session/logind.c:363] Failed to get seat id:
> No data available
> 2018-12-21 18:54:53 - [backend/session/direct.c:159] Could not get current
> tty number: Inappropriate ioctl for device
> 2018-12-21 18:54:53 - [backend/session/session.c:76] Failed to load session
> backend
> 2018-12-21 18:54:53 - [backend/backend.c:250] Failed to start a DRM session
> 2018-12-21 18:54:53 - [rootston/main.c:26] could not start backend
> root at letux:~# cat /etc/debian_version
> buster/sid
> root at letux:~# uname -a
> Linux letux 4.19.12-letux+ #3090 SMP PREEMPT Mon Dec 24 13:47:00 CET 2018
> armv7l GNU/Linux
> root at letux:~#
>
> There is only a (properly rotated!) login: with blinking cursor shown on the
> display.
>
> Trying the same on GTA04A4 has exactly the same error messages but the
> display is even completely inactive.
>
> So there is still a config issue and I have no idea what a "seat id" should
> be...
>
> BR,
> Nikolaus

Hi Nikolaus!

How are you trying to run Phosh? It needs to be run on the tty, so
just launching via ssh won't work. You should either configure
something like systemd service to run it, or use something like
openvt.

Also, Phosh should be run as a normal user, not as root.

Actually, I should probably just look around for some SD card to
install it on... :)

Thanks!
-- 
Sebastian Krzyszkowiak, dos
https://dosowisko.net/


More information about the Community mailing list