[Tinkerphones] A short story about some GTA04 repairs

H. Nikolaus Schaller hns at goldelico.com
Fri Apr 19 08:06:29 CEST 2019


Hi all,
recently, I received a parcel containing 4 GTA04A4 devices which were broken,
and I was asked for a repair.

Well, all of them had broken GPS sockets, which is known to be a weak point
of the GTA04A4 design. The problem is that the socket is surface mounted
and if the PCB is not extracted carefully enough from the case (or if the
GPS antenna cable is pressed in by too much force), the socket is ripped
off the PCB. This was fixed in GTA04A5 by using a THT socket.

Some boards also had problems with a broken off USB socket - mainly the same
issue that it is a SMT part in GTA04A4 and became a THT only in GTA04A5 later.

This is especially problematic if the camera is installed (like on these 4
units). Because then everything fits to 100µm into the case and a single wrong
movement of the PCB can give too much shearing force to the sockets/PCBs.

Additionally, one device did have a broken AUX button and another one a
broken off headset jack.

After doing this optical inspection, I tried to boot the naked boards.

The first board did not boot and I was not able to make it boot by recovery
µSD cards. It did not even show the magic ID string on RS232 which means
the OMAP3 Boot ROM is not running (or RS232 is broken). This needs deeper
analysis and looked to be unrepairable.

The second one did show the ID, but also did not want to boot. Therefore,
I took a recovery µSD (makesd gta04 / makesd gta04a5) and with that one I
could boot a little, but with problems. Therefore, I did break into the U-Boot
console and did erase the MLO and NAND environment:

	nand erase 0 500000

After booting again from µSD the boot loader did flash a new MLO / U-Boot
(red screen) and Linux booted to a login: prompt. So I just had to look how
to repair the ripped off sockets (unfortunately the copper was also ripped
off so it can't be soldered any more to the PCB...).

Next, I tried to run the flash-nand script to get a kernel into NAND, but it appears
that we did miss some typo in the script (and nobody seems to flash new images).
It was a little difficult to debug because it was ${DEV) instead of ${DEV}.
Do you spot the difference? What makes it really difficult to find is that the
shell can't report the precise line number but fails approx. 100 lines later...
So we have another patch already included in letux-5.1-rc3, letux-5.0-next
letux-4.20-next and letux-4.19-next.

The third device did show the same effects as the second one.

The fourth board did boot from NAND into an LXDE environment, and interestingly
it was a very old setup: a letux-3.7-offmode kernel compiled in June 2013 and
an U-Boot compiled in Feb 2014. I didn't know that our 5 years old software
is still in use :)

So at this point it appeared that 3 out of 4 boards "just" need hardware
micro-surgery to get the sockets and pushbuttons (or replacements) into
a better shape again.

Then I started to repair them. Reinstalling USB or GPS sockets is not easy
and it is more difficult if the copper pads are ripped off. So this required
to invent some tricks how to fasten them to the PCB. More like microsurgery
or a dentist's work by adding small stabilizer wires... They must not bee too
thin to be stiff enough and not too thick so that they fit. And they must
be solderable i.e. made of copper or brass.

After investing a lot of time, I managed to get two of them repaired.

The owner also had asked if I could install an ambient light sensor as
suggested in the GTA04 manual. This was an easy task and I had several TEPT4400
photo-transistors available and it was merely finding out the polarity
and drilling a hole into the front case. The best way to do it is to
insert (bot not solder) the transistor in the soldering pads, place the
GTA04 board (with display installed) onto the front plate of the case
and make a marking where the rounded head of the transistor is. Then drill
a 3mm hole from the inside out. Finally place the PCB with display and
TEPT into the front part so that the TEPT is in the hole. Then solder the
pins and cut them. Voila, done.

It can easily be tested by the /root/blanviewd daemon which is needed
for the Letux3704 (which uses the same sensor and connection to the
tsc2007 touch screen controller).

So I finally could send the two units out and two more were waiting that I
find the time to take care of them.

On Wednesday I found the time to take care of the remaining two and
managed to repair them as well. Fixing the sockets was just microsurgery
again and while doing that I noticed that two capacitors were missing
near the GPS receiver module. It turned out that they are 100nF and
belong to the RS232 charge pump. So this explained why the broken board
did not even report the magic ID. There was no power for RS232. After
reinstalling them I could start the board, flash a newer U-Boot and
everything went fine.

The most problematic was the ripped off headset socket. It has only
weak solder tabs, is mostly plastic. This differs from the USB and
GPS sockets which have a metal case. So it is not possible to solder
it to some stabilizer wires. Rather I had to glue the socket to the
PCB and then solder tiny wires to reestablish the electrical connection.
Fortunately there are always capacitors or resistors nearby where the
signal can be tapped from. Let's hope that the glue is sufficiently
strong... I did not want to take more because I do not want to have
the glue go inside the socket.

In total it was a lot of work but shows how robust and repairable the
GTA04 is. Even ca. 7 years after being built. But I do not really want
to repeat such repairs. Except it gave me some new motivation to try
again the GTA04A5 boards which are still waiting for PoP Memory and
OMAP3 replacement. As soon as I find spare time or sponsors who help
to raise priority over well paid projects...

I hope you like this story and maybe it contains some ideas how to revive
your GTA04... And maybe you can share your own current GTA04 story.

Nikolaus



More information about the Community mailing list