[Tinkerphones] [Gta04-owner] Phosh/Librem5 system on a GTA04

Andreas Kemnade andreas at kemnade.info
Sun Dec 30 00:07:37 CET 2018


On Fri, 28 Dec 2018 19:55:43 +0100
Mark Müller <markmueller86 at gmail.com> wrote:

> Hi,
> 
> having some time to toy around with my good ol' GTA04 during the
> holidays, I upgraded a current Letux Debian/LXDE image with kernel
> 4.19.10-letux+ on the SD card to Debian Buster and installed the Librem5
> base system. After that, I had a GTA04 with a Phosh shell starting up -
> yeah!!
> 
> What I tested so far:
> 
> * USB access via SSH still working
> * Bluetooth is working from the command line (mouse and keyboard connected)
> * WLAN is working from the command line (network-manager)
> * WWAN is working from the command line (modem-manager)
> * Touch input is partially working (libinput registers events, but touch
> input under Phosh doesn't work as expected)
> * It's really, really (!!) slow as it seems to use llvmpipe (Phosh uses
> rootston as  wayland compositor)
> 
> That's roughly what I did to get it working:
> 
> * Install LXDE image on a SD card via makesd (see
> https://projects.goldelico.com/p/gta04-makesd/)
> * Boot the image and connect to the GTA04 via USB and update all packages
> * Change sources from jessie to buster (in /etc/apt/sources.list and
> /etc/apt/sources.list.d/*)
> * Include the Librem5 repositories (echo "deb https://ci.puri.sm/
> scratch librem5" > /etc/apt/sources.list.d/ci.list)
> * Add the key for the new repository (wget -O -
> https://ci.puri.sm/ci-repo.key | sudo apt-key add -)
> * apt update; apt upgrade (I did not dist-upgrade at this point, but it
> shouldn't hurt)
> * apt install librem5-base librem5-base-defaults librem5-gnome
> librem5-gnome-base librem5-gnome-phone (this will remove some packages!)
> * If not done before, upgrade all remaining packages with a dist-upgrade
> (probably removing some packages in this course)
> * Reboot and see Phosh starting (I hope so)
> 
> Caution: This how-to is from memory - it could be missing some steps,
> have typos or maybe it doesn't work at all for you ;-)
> 
adduser purism
is important.

I started a fresh debian buster using a patched
cdebootstrap/libinstaller 
  (see https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=904699)

Now I am with a non-working touchscreen but screen output.

Regards,
Andreas
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 833 bytes
Desc: OpenPGP digital signature
URL: <http://lists.goldelico.com/pipermail/community/attachments/20181230/53acb823/attachment.asc>


More information about the Community mailing list