[Tinkerphones] Status GTA04 Hardware & Software

H. Nikolaus Schaller hns at goldelico.com
Fri Apr 14 19:18:13 CEST 2017

let me give a short status update:

1. GTA04 Hardware

* shipment of GTA04A5 and Letux 2804
the first GTA04A5 boards have been shipped this
week as well as some Letux 2804 (complete devices).
I hope they arrive(d) well and new users will appear
here soon.

* repairs of other GTA04A5: I have picked up the
unused components yesterday and now I have more than
enough material to try repairs. I can't tell yet
how fast and successful it will become but will keep
you updated.

2. Software for GTA04

* Kernel: Finally I have managed to fix two issues in
the Letux-4.11-rc6 kernel so that it now boots successful.
This makes it possible for the first time to test 4.11

There are more known issues and we will try to fix them.
Maybe not before 4.11.0 is published in 2 weeks, but soon.

Also, we have a Letux-4.10.10 kernel which should be
robust and stable for your projects.

* NAND image: is Debian 8.7 (Jessie) + LXDE. This is
more a demo and hardware test than a useable device
GUI. It is neither finger compatible nor does it have
many functions. Running GPS-Demo, Camera-Demo and
SimpleGSM-HUI seems to be not reliable and after
booting a nasty "PID not found" message pops up.
The last one is related to LXDE. I even tried with
an experimental Stretch system but the error remains.
Maybe, some LXDE component is misconfigured.

* Replicant/Android 4.2: has got a -v2 which includes the
letux-4.10 kernel. This is required to be able to
run Replicant on the GTA04A5 (which has different
device tree and drivers). Unfortunately, Lukas
recently did not have as much time as before so
we lack some modification to test and make it useable
for daily operation. Especially accelerometers,
and modem power/AT commands may need improvements
for the GTA04A5.

* Replicant 6.0: AFAIK currently nobody is really
working on it. I tried to setup a build system
on my non-Debian host but failed so far. Even for
Replicant-4.2 (seems to be some 32/64 bit issues
and C++0x vs. C++11 and JDK version mismatch).
But the build instructions should work:
if you run a compatible host.

* QtMoko: unfortunately nobody was able to get
it compiled on a more modern Debian foundation.
Therefore we only have the old 3.7-kernel based
binary images. Those can not be booted on GTA04A5
devices because the kernel is too old.

It is possible to substitute the latest kernel,
but like with Replicant, the modem and peripheral
interfaces have changed and therefore it is not

If anyone wants to help with these issues, please
raise your fingers and roll up your sleeves. It is
a very good opportunity to learn and contribute to
our community (both are the factors why I am not
giving up, although I have had enough reasons to
do so :).


Kernel: http://projects.goldelico.com/p/gta04-kernel/
LXDE: http://projects.goldelico.com/p/gta04-rootfs/
Replicant: http://projects.goldelico.com/p/gta04-replicant/
QtMoko: http://www.qtmoko.net

More information about the Community mailing list