[Community] Report on QtMoko

David Boddie david at boddie.org.uk
Wed Jun 15 12:01:13 CEST 2016

On Tue Jun 14 16:41:23 CEST 2016, Josua Mayer wrote:

> When touching the screen, Qt properly detects a mouse-press at the right
> location of the screen. But then when moving the pointer, it runs away
> in a non-linear fashion.
> I later concluded that it looks like this:
> pos_new = new_absolute_coordinates + distance_to_last_position
> This is a serious issue and needs investigating. We suspect that the
> Qt-Embedded LinuxTP mouse driver is doing something nasty!

A quick suggestion that might not be practical: have you tried using the
linuxinput driver instead?


For example, when I compiled Qt for the Kobo Mini, I compiled it with
linuxinput support (-qt-mouse-linuxinput) and selected the driver using an
environment variable at run-time:


I've always had difficulty with tslib but linuxinput has mostly worked for
me, once I've figured out which device file it needs to read from.


More information about the Community mailing list