[Community] What software are we still missing on GTA04 distributions?

NeilBrown neilb at suse.de
Thu Jul 26 13:01:30 CEST 2012


On Thu, 26 Jul 2012 10:11:42 +0200 "Dr. H. Nikolaus Schaller"
<hns at goldelico.com> wrote:

> 
> Am 26.07.2012 um 00:52 schrieb NeilBrown:
> 
> > On Wed, 25 Jul 2012 11:00:41 +0200 "Dr. H. Nikolaus Schaller"
> > <hns at goldelico.com> wrote:
> > 
> >> Please just write down what you are missing. This might help the
> >> software projects to get directions and motivation (because someone
> >> is interested in their work).
> >> 
> > 
> >> Other:
> >> * 
> >> * 
> > 
> > Reliable firmware for the GSM module?
> > 
> > I've recently started noticing the problem where an incoming call causes the
> > firmware to crash on occasion.  I think Radek avoided that by disabling 3G or
> > similar (Radek: what was the command to do that?).
> > 
> > Also sometimes it just fails to register properly - it is weird.  It seems 
> > to be registered and knows which carrier it is with and gets signal strength
> > updates, but incoming and out-going calls just don't work.  Even a
> > power-cycle doesn't fix things.
> 
> > I pull the SIM out and put it in another phone and it works fine.  Put it
> > back in the GTA04 again, and it works again.
> 
> This may also be related to a misaligned antenna. I.e. it can happen
> that the reception is good enough to receive the beacon signals from
> the base stations but transmitted signals are too weak to arrive there.

That sounds entirely possible.

When I first tried 3G data access with a bit of wire attached to a bare board
with a cloths peg, I got 60KB/sec download.  With the board on the case I
never get anywhere near that - maybe 10KB/sec.

In marginal coverage areas, my wifes sony/ericson gets much better reception
that my GTA04.

And it is quite possible that the SMS problems are related to poor signal
strength.

I wonder if I just need to clean a contact or something...

> 
> > Also I don't get cell-id updates (in .au most cells report a name saying
> > which suburb they are in).  That all worked with GTA02, but not with GTA04.
> > 
> > Sometimes when I send a TXT the response seems to indicate that it wasn't
> > sent, but actually it was.  I don't have logs of exactly what the response is
> > in that case.
> > 
> > So if there were some way to try out a newer firmware, I'd be keen to give it
> > a go.
> 
> I will take another look into that after solving production things and holidays.
> So it may take a while for news.

Thanks!  One thing at a time.

NeilBrown



> 
> Nikolaus

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 828 bytes
Desc: not available
URL: <http://lists.goldelico.com/pipermail/community/attachments/20120726/9f1f8764/attachment.asc>


More information about the Community mailing list