[Letux-kernel] U-Boot Watchdog?

H. Nikolaus Schaller hns at goldelico.com
Fri Mar 17 23:09:13 CET 2017


Have found it :)

The ca. 9 seconds was the hint...

The PCB didn't fit exactly in the case and hence the Power button was
always pressed. This triggers the 8-seconds emergency power-down - after
enabling it by MLO which differs a little in timing between NAND and MMC
boot.

Ok. We have learned something :)

BR,
Nikolaus



> Am 17.03.2017 um 23:06 schrieb H. Nikolaus Schaller <hns at goldelico.com>:
> 
> 
>> Am 17.03.2017 um 22:55 schrieb H. Nikolaus Schaller <hns at goldelico.com>:
>> 
>> Hi,
>> 
>>> Am 17.03.2017 um 22:45 schrieb Belisko Marek <marek.belisko at gmail.com>:
>>> 
>>> Hi Nikolaus,
>>> 
>>> 
>>> On Fri, Mar 17, 2017 at 8:18 PM, H. Nikolaus Schaller <hns at goldelico.com> wrote:
>>>> Hi,
>>>> I have one strange problem on one of my GTA04A4 devices.
>>>> 
>>>> I can boot from NAND or MMC and break into U-Boot.
>>>> 
>>>> But after ca. 5-10 seconds the boards simply reboots.
>>>> It is quite reproducible and looks like a watchdog
>>>> timer...
>>> watchdog timeout is set to 60secs so it's unlikely it's reboot by
>>> watchdog (drivers/watchdog/omap_wdt.c)
>> 
>> It is just sufficient time to break into the U-Boot console
>> and start typing.
>> 
>> Or approx. the same time booting into Linux.
>> 
>> So it is more a 10 second "timeout" triggered by U-Boot having initialized :)
>> 
>>> it's reproducible 100% only on one board? thanks.
>> 
>> Yes. I have never seen that on any other board. Even when swapping the
>> boot-SD card to others.
>> 
>> Maybe something in the twl4030 is broken?
>> 
>> What I have not tried to find out is if power consumption raises. Or
>> if the charging circuits are damaged. That might decrease system voltage
>> below the auto-power-off. But then it should no start over.
>> 
>> And, I should try to find out if the delay until reboot is always the
>> same.
> 
> It appears to be always 7-8 seconds after inserting battery. Independent
> of using the AUX button for the U-Boot Menu. Or using a different battery.
> 
> The only small difference is when booting from SD-Card. Then it is 9 seconds.
> 
> It also doesn't matter if NAND is flashed :(
> 
>> 
>>>> 
>>>> It is the first time in 6 years I have seen this...
>>>> 
>>>> And: it is exactly the same SD card I had used to reflash
>>>> and test two other boards before.
>>>> 
>>>> Any ideas?
>>>> 
>>>> BR,
>>>> Nikolaus
>>>> 
>>>> _______________________________________________
>>>> http://projects.goldelico.com/p/gta04-kernel/
>>>> Letux-kernel mailing list
>>>> Letux-kernel at openphoenux.org
>>>> http://lists.goldelico.com/mailman/listinfo.cgi/letux-kernel
>>> 
>>> BR,
>>> 
>>> marek
>> 
>> BR and thanks,
>> Nikolaus
>> 
>> _______________________________________________
>> http://projects.goldelico.com/p/gta04-kernel/
>> Letux-kernel mailing list
>> Letux-kernel at openphoenux.org
>> http://lists.goldelico.com/mailman/listinfo.cgi/letux-kernel
> 
> _______________________________________________
> http://projects.goldelico.com/p/gta04-kernel/
> Letux-kernel mailing list
> Letux-kernel at openphoenux.org
> http://lists.goldelico.com/mailman/listinfo.cgi/letux-kernel



More information about the Letux-kernel mailing list