[Letux-kernel] Letux U-Boot 2016.11 for GTA04

Andreas Kemnade andreas at kemnade.info
Sat Jan 14 20:49:38 CET 2017


On Fri, 13 Jan 2017 22:04:59 +0100
"H. Nikolaus Schaller" <hns at goldelico.com> wrote:

> That is "development" :) Otherwise it would be "consuming".
> 
That was doing stupid things by me.

> I found some time to test the latest u-boot and kernel on
> the Letux 3704 (gta04b2) and it boots. It shows the same
> problem as the gta04 that booting from NAND does not find
> the MMC. So I think this is the most urgent fix I should
> work on.
> 

I did some experiments:
booting from mmc and power off

---------------------
U-Boot SPL 2016.11-01272-g256741c (Jan 11 2017 - 22:18:06)
Trying to boot from MMC1
pop_mfr = 2c pop_id = bc
Found GTA04A4
reading u-boot.img
reading u-boot.img


U-Boot 2016.11-01272-g256741c (Jan 11 2017 - 22:18:06 +0100)

OMAP36XX/37XX-GP ES1.2, CPU-OPP2, L3-200MHz, Max CPU Clock 1 Ghz
GTA04 + LPDDR/NAND
I2C:   ready
DRAM:  512 MiB
NAND:  512 MiB
MMC:   OMAP SD/MMC: 0
OMAP die ID: 26d600229ff800000168300f0f02901d
Found GTA04A4
Device Tree: omap3-gta04a4+b2.dtb
Net:   usb_ether
Error: usb_ether address not set.

Hit any key to stop autoboot:  0 
GTA04b2 # 
GTA04b2 # power off
gpio_omap: dir_output: error: gpio 20 not reserved
shutting down by writing DEVOFF register of TPS65950

-----------------
that gpio 20 message is strange.
just pressing power button and output partition table

-------------------


U-Boot SPL 2016.11-01272-g256741c (Jan 11 2017 - 22:18:06)
Trying to boot from NAND


U-Boot 2016.11-01272-g256741c (Jan 11 2017 - 22:18:06 +0100)

OMAP36XX/37XX-GP ES1.2, CPU-OPP2, L3-200MHz, Max CPU Clock 1 Ghz
GTA04 + LPDDR/NAND
I2C:   ready
DRAM:  512 MiB
NAND:  512 MiB
MMC:   OMAP SD/MMC: 0
OMAP die ID: 26d600229ff800000168300f0f02901d
Found GTA04A4
Device Tree: omap3-gta04a4+b2.dtb
Net:   usb_ether
Error: usb_ether address not set.

Hit any key to stop autoboot:  0 
GTA04b2 # mmc part

Partition Map for MMC device 0  --   Partition Type: DOS

Part    Start Sector    Num Sectors     UUID            Type
  1     128             778233          00000000-01     0c Boot
  2     778361          14786439        00000000-02     83
GTA04b2 # power off
gpio_omap: dir_output: error: gpio 20 not reserved
shutting down by writing DEVOFF register of TPS65950

-------------------------------------------------------------------------------
removing battery and reattaching it. Now the mmc does not work.
Is power off not really power off?
Or is mmc just initialized too early when power is still unstable and
does not work because of that.
Just like the situation with my sd at my bicycle...


----------------------------------------------------------------------------------

U-Boot SPL 2016.11-01272-g256741c (Jan 11 2017 - 22:18:06)
Trying to boot from NAND

U-Boot SPL 2016.11-01272-g256741c (Jan 11 2017 - 22:18:06)
Trying to boot from NAND


U-Boot 2016.11-01272-g256741c (Jan 11 2017 - 22:18:06 +0100)

OMAP36XX/37XX-GP ES1.2, CPU-OPP2, L3-200MHz, Max CPU Clock 1 Ghz
GTA04 + LPDDR/NAND
I2C:   ready
DRAM:  512 MiB
NAND:  512 MiB
MMC:   OMAP SD/MMC: 0
OMAP die ID: 26d600229ff800000168300f0f02901d
Found GTA04A4
Device Tree: omap3-gta04a4+b2.dtb
Net:   usb_ether
Error: usb_ether address not set.

Hit any key to stop autoboot:  0 
GTA04b2 # 
GTA04b2 # 
GTA04b2 # mmc rescan
Card did not respond to voltage select!
GTA04b2 # mmc part
Card did not respond to voltage select!
GTA04b2 # 


Regards,
Andreas
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 819 bytes
Desc: OpenPGP digital signature
URL: <http://lists.goldelico.com/pipermail/letux-kernel/attachments/20170114/c44741b0/attachment.asc>


More information about the Letux-kernel mailing list