[Letux-kernel] Letux U-Boot 2016.11 for GTA04

H. Nikolaus Schaller hns at goldelico.com
Sun Jan 8 12:52:14 CET 2017


Hi,
the latest U-Boot is starting to work on GTA04 as well :)
[it already works for a while on Pyra and Letux Cortex 8]

Everything is fine when booting from µSD.
This includes a reworked the boot.scr.

And I have worked on adding OneNAND support (GTA04, Neo900)
and making the new MLO/U-Boot boot from flash.

This basically also works. At least the MLO/X-Loder
and loading U-Boot for NAND.

If booting from NAND (GTA04A3/A4) U-Boot does not find
the MMC card. It says it can not control power. Strange.

But I can imagine that U-Boot assumes that the MMC power
has already been initialized by MLO when booting from µSD
and simply doesn't do it again.

For OneNAND (GTA04A5) the problem is a little different.
Basically flashing the OneNAND seems to work, but shows
strange effects. E.g. telling that it wrote 0 bytes but
still says OK.

The effect is that the MLO from OneNAND does not boot
because it is not there...

This all could have its reason in a different block
size of the OneNAND.

And I remember from the tests done some years ago that
OneNAND is organised as 16 bit and the MLO reads 8 bits
only. So it was required to pad the MLO binary for OneNAND
when flashing (which is something I have not tried yet).

So still some cm to drill through granite :)

If you want to take a look (and help?):

	http://git.goldelico.com/?p=gta04-uboot.git;a=shortlog;h=refs/heads/letux-2016.11

BR,
Nikolaus



More information about the Letux-kernel mailing list