[Letux-kernel] Charging on GTA04

Belisko Marek marek.belisko at gmail.com
Tue Jun 28 21:45:00 CEST 2016


Hi Nikolaus,

On Tue, Jun 28, 2016 at 9:42 PM, H. Nikolaus Schaller <hns at goldelico.com> wrote:
> Hi Marek,
>
>> Am 28.06.2016 um 20:55 schrieb Belisko Marek <marek.belisko at gmail.com>:
>>
>> Hi Nikolaus,
>>
>> On Tue, Jun 28, 2016 at 10:47 AM, H. Nikolaus Schaller
>> <hns at goldelico.com> wrote:
>>> Hi Marek,
>>>
>>>> Am 27.06.2016 um 22:26 schrieb Belisko Marek <marek.belisko at gmail.com>:
>>>>
>>>> Hi Nikolaus,
>>>>
>>>> I build fresh 4.7-rc5-letux (make mrproper
>>>
>>> I never heard about make mrproper. What is the difference to make clean?
>>>
>>> Anyways I never had issues and rarely did have to make clean when
>>> switching branches.
>>>
>>>> ARCH=arm; make
>>>> letux_defconfig ARCH=arm) boot device and twl4030_usb is reporting:
>>>> root at letux:~# cat /sys/class/power_supply/twl4030_usb/status
>>>> Charging
>>>> root at letux:~# cat /sys/class/power_supply/twl4030_usb/voltage_now
>>>> 4961175
>>>> root at letux:~# cat /sys/class/power_supply/twl4030_usb/current_now
>>>> 509352
>>>>
>>>> genric-adc-battery has bug that despite of fact that twl4030 report
>>>> charging generic adc-batt report discharging. Also eth gadget works
>>>> for me. Strange.
>>>
>>> Can we do this test:
>>>
>>> please install (step by step boot and verify):
>>> * device-trees
>> OK
>>> * modules
>> After updating modules  eth gadget doesn't work
>
> Ok, that is strange! Well, the depmod database may be out of sync.
>
>> but charging seems to
>> be fine also wifi is up & running:
>> USB
>> POWER_SUPPLY_NAME=twl4030_usb
>> POWER_SUPPLY_STATUS=Charging
>> POWER_SUPPLY_ONLINE=1
>> POWER_SUPPLY_VOLTAGE_NOW=4974861
>> POWER_SUPPLY_CURRENT_NOW=507690
>> POWER_SUPPLY_INPUT_CURRENT_LIMIT=499381
>> 4974861
>
> ok.
>
>>
>>> * uImage
>
> did you also try to replace the uImage?
Nope.
>
> The more I think about it, it could indeed be:
>
>>>
>>> If compiler issues can be excluded, we could also have a user-space
>>> influence (fstab, inittab, udev rules or whatever).
>
> What are you using as user-space?
> Do you have installed the Letux udev rules?
Yes it was oart of modules so I replaced it and I'm running on Debian
GNU/Linux 8.
>
> BR and thanks,
> Nikolaus
> _______________________________________________
> http://projects.goldelico.com/p/gta04-kernel/
> Letux-kernel mailing list
> Letux-kernel at openphoenux.org
> http://lists.goldelico.com/mailman/listinfo.cgi/letux-kernel

BR,

marek

-- 
as simple and primitive as possible
-------------------------------------------------
Marek Belisko - OPEN-NANDRA
Freelance Developer

Ruska Nova Ves 219 | Presov, 08005 Slovak Republic
Tel: +421 915 052 184
skype: marekwhite
twitter: #opennandra
web: http://open-nandra.com


More information about the Letux-kernel mailing list