[Letux-kernel] Charging on GTA04

H. Nikolaus Schaller hns at goldelico.com
Tue Jun 28 10:47:56 CEST 2016


Hi Marek,

> Am 27.06.2016 um 22:26 schrieb Belisko Marek <marek.belisko at gmail.com>:
> 
> Hi Nikolaus,
> 
> I build fresh 4.7-rc5-letux (make mrproper

I never heard about make mrproper. What is the difference to make clean?

Anyways I never had issues and rarely did have to make clean when
switching branches.

> ARCH=arm; make
> letux_defconfig ARCH=arm) boot device and twl4030_usb is reporting:
> root at letux:~# cat /sys/class/power_supply/twl4030_usb/status
> Charging
> root at letux:~# cat /sys/class/power_supply/twl4030_usb/voltage_now
> 4961175
> root at letux:~# cat /sys/class/power_supply/twl4030_usb/current_now
> 509352
> 
> genric-adc-battery has bug that despite of fact that twl4030 report
> charging generic adc-batt report discharging. Also eth gadget works
> for me. Strange.

Can we do this test:

please install (step by step boot and verify):
* device-trees
* modules
* uImage

from

http://download.goldelico.com/letux-kernel/letux-4.7-rc5/

over your running system?

At least we can then exclude a compiler or compilation bug...

I will in parallel recompile 4.3 from source and try to boot that one.
And check for significant diffs to the old version at http://download.goldelico.com/letux-kernel/4.3/
(what an Archive of build results can be good for :)

If compiler issues can be excluded, we could also have a user-space
influence (fstab, inittab, udev rules or whatever).

BR and thanks,
Nikolaus





More information about the Letux-kernel mailing list