<html><body><div style="color:#000; background-color:#fff; font-family:times new roman, new york, times, serif;font-size:12pt"><div><span>Hi all,</span></div><div><br><span></span></div><div><span>Flashed the v45 ubi file and kernel (3.4). Tested without an SD card installed. Still had the same general issues - suspend not working, SMSes not being received.</span></div><div><br><span></span></div><div><span>Flashed the v44 ubi file and kernel (3.2). Tested without the SD card installed. Suspend working, </span><span> SMSes not being received.</span></div><div><br><span></span></div><div><span>I am not sure why v44 with the 3.2 kernel suspends and v45 with the 3.4 kernel does not. Is there some way for me to test suspend from the command line without Qtmoko running, and then incrementally simulate what Qtmoko does so that we can get some diagnostics on this (I am an enterprise level Java programmer that has dabbled a bit in C, C++ and Objective C so you
 can hit me with as much technical detail as you like (I also have a bit of time up my sleeve))?</span></div><div><br><span></span></div><div><span>I will gather some loggin shortly with v45 regarding SMS receipt - is this just a case of turning on logging within Qtmoko or does it require something else?<br></span></div><div><br><span></span></div><div><span>Kev<br></span>
</div><div><br></div>  <div style="font-family: times new roman, new york, times, serif; font-size: 12pt;"> <div style="font-family: times new roman, new york, times, serif; font-size: 12pt;"> <div dir="ltr"> <font face="Arial" size="2"> <hr size="1">  <b><span style="font-weight:bold;">From:</span></b> Neil Jerram <neil@ossau.homelinux.net><br> <b><span style="font-weight: bold;">To:</span></b> List for communicating with real GTA04 owners <gta04-owner@goldelico.com> <br><b><span style="font-weight: bold;">Cc:</span></b> Kevin Hremeviuc <khremeviuc@yahoo.com> <br> <b><span style="font-weight: bold;">Sent:</span></b> Saturday, June 16, 2012 5:43 PM<br> <b><span style="font-weight: bold;">Subject:</span></b> Re: [Gta04-owner] QTMoko v45 bugs<br> </font> </div> <br>Radek Polak <<a ymailto="mailto:psonek2@seznam.cz" href="mailto:psonek2@seznam.cz">psonek2@seznam.cz</a>> writes:<br><br>> On Saturday 16 June 2012 04:04:17 Kevin
 Hremeviuc wrote:<br>><br>>> I have been using the gta04 QTMoko v45 for a couple of days now and have<br>>> found a couple of bugs:<br>>> <br>>> 1. Suspend does not seem to be working. Tapping on the screen wakes the<br>>> device up. Since the screen can easily be bumped this could waste a lot of<br>>> energy, especially if I have the phone in my jeans pocket. If this is a<br>>> suspended state then my battery usage rate is too high - I have about<br>>> 16hrs before it is flat. I am in a weak reception area - would this<br>>> consume a significant amount of power?<br>><br>> Screen tap should not wake GTA04 - so it looks the device is not really <br>> suspended.<br>><br>> How are you suspending it? I am always locking the screen - the phone suspends <br>> then after 10s. For me this works very good. GTA04 should remain 2 days in <br>> suspend with fresh battery.<br><br>I
 sometimes lock, and sometimes just leave it to suspend after 3<br>minutes.  Both seem to work reliably for me; I don't recall any<br>unexpected wake ups.<br><br>By the way, if the phone _isn't_ locked when it suspends, should it be<br>automatically locked on resume?  Otherwise, if it's in your pocket, the<br>pocket could do something unwanted, and also prevent re-suspending.<br><br>On the other hand, how does that interact with the case of wanting to<br>quickly answer an incoming call?  I imagine there's a well known<br>solution to this, as it affects all phones; but I don't know what it is<br>yet.<br><br>> I think i will add indicator for current_now to the home screen, so that you <br>> can see how much milliamps the phone draws from battery (you can see it now in <br>> NeoControl application).<br><br>That sounds useful.<br><br>>> 2. I am not receiving SMSes. The screen turns on, there is no sound and<br>>> there is
 no message saying that an SMS has been received. When I restart<br>>> just QTMoko using the menu I then get a message that an SMS has been<br>>> received.<br><br>> Is this reproducible? Can you provide log with "Modem AT commands" category <br>> enabled?<br><br>I see this problem too; but not enough yet to say how reproducible it<br>is.<br><br>>> 4. Sometimes, after a couple of suspends, the phone goes to sleep and can<br>>> not be woken up.<br><br>I've never seen this.<br><br>> My phone suspends/resumes very reliably.<br><br>>> Is it just me having these issues? How many people are using QTMoko v45<br>>> actively?<br>><br>> That would be interesting to know. Is anyone using GTA04 as his daily phone?<br><br>I'm using it daily as a pressure monitor and navigation device, and it's<br>fantastic for that; but not really as a phone yet.  I think the latter<br>is because my current pattern of
 communication doesn't much require a<br>mobile phone, and also because I haven't yet copied much contact<br>information onto the phone.<br><br>Regards,<br>        Neil<br><br><br> </div> </div>  </div></body></html>