[Gta04-owner] Testers needed for upgrading your GTA04 to U-Boot 2016.11 + Letux-4.10.4 + Debian/LXDE 8.7

Andreas Kemnade andreas at kemnade.info
Sat Mar 25 16:30:22 CET 2017


Hi,

On Mon, 20 Mar 2017 12:42:44 +0100
"H. Nikolaus Schaller" <hns at goldelico.com> wrote:

> Hi,
> in parallel to trying to handle all the other GTA04 tasks, I have fixed
> some minor issues in kernel, u-boot and rootfs so that we have first release 
> candidate for a new production SD image.
> 
> A production SD image is used for flashing (unbricking) a GTA04 device.
> The last one [1] was based on kernel 3.12 and Debian Wheezy which wasn't
> bad at all, but did not support the OneNAND of the GTA04A5.
> 
> The biggest visual change is that there are some LXDE desktop icons for
> starting Simple-Gsmgui [2] (developed by our commmunity member akemnade),
> Camera Demo (camera driver is not working) and GPS demo (well this is
> not even a demo but full FoxtrotGPS). So it should become possible to
> operate the most basic functions from NAND only.
> 
> If you have a little time and want to test/upgrade, please follow
> these instructions and report issues and observations.
> 
> Please note that if anything fails you might need the RS232 cable
> and the original production image [1].
> 
> And as a goodie, there is a tiny video of the GPS demo on the GTA04A5: [3]
> 
> BR and have fun,
> Nikolaus
> 
> 
> 1. for GTA04A3/4 use maksd [4] to format a "production SD card":
> 
> 	DEV=/dev/sdd ./makesd gta04
> 
> or for GTA04A5 (OneNAND):
> 
> 	DEV=/dev/sdd ./makesd gta04one
> 
> The reason is that they need differently compiled SPL/U-Boot.
> 
> The following procedures do not differ between GTA04A* versions.
> 
> 2. boot the GTA04 with this SD card while pressing the AUX button.
> The LCD will turn red while flashing the NAND with MLO/SPL and U-Boot.
> 
> If that fails you might need to break into the U-Boot console and do
> 
> 	nand erase 0x280000 0x80000
> 
> This wipes out the old U-Boot environment and U-Boot. And then reflash.
> 
> After a while Linux will start, but please reboot once to "wake up"
> some parts of the installation.
> 
> 3. log in (console: root/empty or through USB cable and ssh root at 192.268.0.202)
> 
> Connect to Internet through USB and configure host for IP forwarding.
> I.e. ping to outside addresses should be working.
> 
> Then:
> 
> 	apt-get update
> 	yes | DEBIAN_FRONTEND=noninteractive apt-get install letux-lxde
> 
> 4. flash kernel and rootfs to NAND by running on the GTA04
> 
> 	./flash-nand -f -k -u
> 
> This will be the procedure of factory flashing.
> 
Tested on gta04a4:
This does not flash dt for some reason...

bootm fails after that.

But: A second run with  just -k does indeed copy  the dt.

Next thing which is missing the hso module on nand!

Regards,
Andreas
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 819 bytes
Desc: OpenPGP digital signature
URL: <http://lists.goldelico.com/pipermail/gta04-owner/attachments/20170325/3eff7487/attachment.asc>


More information about the Gta04-owner mailing list