[Gta04-owner] GTA04A5 charging?

H. Nikolaus Schaller hns at goldelico.com
Mon Jul 10 21:18:39 CEST 2017


Hi Martin,

> Am 10.07.2017 um 21:06 schrieb Martin Rottensteiner <martin.rottensteiner.list at gmail.com>:
> 
> Hi,
> 
> I just got it in the mean time that the phone really starts on itself after plugging charger and cable (I have to wait some minutes).
> Then I get the boot screen where I can choose the partition where to boot the system from.

Press "OFF" here as quickly as possible. It will turn off the GTA04 - but will continue trickle charging even if voltage becomes higher.

After a while the battery should have become full enough to boot Linux until it enables full charging to get to 100%.

> From this point on I wait about 15 sec, then the screen turns off and power button turns from red to off.

Looks like empty battery (<3.2V). It charges in trickle charge mode (~100mA) until the GTA04 turns on. Then, U-Boot and Display and Linux etc.
draw ca. 400mA which is more than trickle charging supplies. Therefore the battery starts discharging which holds approx. 15 seconds you see.
If Linux boots fast enough it would enable 500mA charging. If not, the battery is drained to the auto-power-off point.

> There is no difference if I just wait at the boot screen or try to boot debian lxde or latest replicant (sms hack).
> 
> It looks for me that the battery is not fully charged and I don't know how to charge it. 
> 
> Please help :)

Please let us know if that helps,
Nikolaus



More information about the Gta04-owner mailing list