[Gta04-owner] Status GTA04 Hardware & Software

Thierry GRAUSS tgrauss at f-gp.eu
Fri Apr 14 19:47:59 CEST 2017


Hi,

I will try to make qtmoko working on the gta04a5 as I don't like
android.
QTMoko has quite a nice interface compared to other.
I am currently trying to find documentation as starting point to build
it but this link is not very current :
http://wiki.openmoko.org/wiki/QtMoko/CrossBuildingOnDebian

So if someone has a good up to date documentation to build qtmoko, it
would help me a lot. After this, if there is problem, I will try
overcome one problem after the other.

I have some ideas for additional programs for QTMoko, but first we need
to have a stable plateform.

Thank you

Regards

On Fri, 14 Apr 2017 19:18:13 +0200
"H. Nikolaus Schaller" <hns at goldelico.com> wrote:

> Hi,
> let me give a short status update:
> 
> 1. GTA04 Hardware
> 
> * shipment of GTA04A5 and Letux 2804
> the first GTA04A5 boards have been shipped this
> week as well as some Letux 2804 (complete devices).
> I hope they arrive(d) well and new users will appear
> here soon.
> 
> * repairs of other GTA04A5: I have picked up the
> unused components yesterday and now I have more than
> enough material to try repairs. I can't tell yet
> how fast and successful it will become but will keep
> you updated.
> 
> 2. Software for GTA04
> 
> * Kernel: Finally I have managed to fix two issues in
> the Letux-4.11-rc6 kernel so that it now boots successful.
> This makes it possible for the first time to test 4.11
> kernels.
> 
> There are more known issues and we will try to fix them.
> Maybe not before 4.11.0 is published in 2 weeks, but soon.
> 
> Also, we have a Letux-4.10.10 kernel which should be
> robust and stable for your projects.
> 
> * NAND image: is Debian 8.7 (Jessie) + LXDE. This is
> more a demo and hardware test than a useable device
> GUI. It is neither finger compatible nor does it have
> many functions. Running GPS-Demo, Camera-Demo and
> SimpleGSM-HUI seems to be not reliable and after
> booting a nasty "PID not found" message pops up.
> The last one is related to LXDE. I even tried with
> an experimental Stretch system but the error remains.
> Maybe, some LXDE component is misconfigured.
> 
> * Replicant/Android 4.2: has got a -v2 which includes the
> letux-4.10 kernel. This is required to be able to
> run Replicant on the GTA04A5 (which has different
> device tree and drivers). Unfortunately, Lukas
> recently did not have as much time as before so
> we lack some modification to test and make it useable
> for daily operation. Especially accelerometers,
> and modem power/AT commands may need improvements
> for the GTA04A5.
> 
> * Replicant 6.0: AFAIK currently nobody is really
> working on it. I tried to setup a build system
> on my non-Debian host but failed so far. Even for
> Replicant-4.2 (seems to be some 32/64 bit issues
> and C++0x vs. C++11 and JDK version mismatch).
> But the build instructions should work:
> http://projects.goldelico.com/p/gta04-replicant/page/Replicant-4/
> if you run a compatible host.
> 
> * QtMoko: unfortunately nobody was able to get
> it compiled on a more modern Debian foundation.
> Therefore we only have the old 3.7-kernel based
> binary images. Those can not be booted on GTA04A5
> devices because the kernel is too old.
> 
> It is possible to substitute the latest kernel,
> but like with Replicant, the modem and peripheral
> interfaces have changed and therefore it is not
> useable.
> 
> If anyone wants to help with these issues, please
> raise your fingers and roll up your sleeves. It is
> a very good opportunity to learn and contribute to
> our community (both are the factors why I am not
> giving up, although I have had enough reasons to
> do so :).
> 
> BR,
> Nikolaus
> 
> Kernel: http://projects.goldelico.com/p/gta04-kernel/
> LXDE: http://projects.goldelico.com/p/gta04-rootfs/
> Replicant: http://projects.goldelico.com/p/gta04-replicant/
> QtMoko: http://www.qtmoko.net
> _______________________________________________
> Gta04-owner mailing list
> Gta04-owner at goldelico.com
> http://lists.goldelico.com/mailman/listinfo.cgi/gta04-owner



More information about the Gta04-owner mailing list