[Gta04-owner] 4.3-rc6 available

Andreas Kemnade andreas at kemnade.info
Thu Oct 22 23:11:46 CEST 2015


On Wed, 21 Oct 2015 07:14:04 +0200
"H. Nikolaus Schaller" <hns at goldelico.com> wrote:

> 
> Am 21.10.2015 um 06:49 schrieb H. Nikolaus Schaller <hns at goldelico.com>:
> 
> > 
> > Am 20.10.2015 um 23:19 schrieb Andreas Kemnade <andreas at kemnade.info>:
> > 
> >> Hi,
> >> 
> >> On Mon, 2015-10-19 at 08:39 +0200, H. Nikolaus Schaller wrote: 
> >>> Hi all,
> >>> I have upgraded to 4.3-rc6 and
> >>> * integrated omapdrm drivers (and xorg.conf)
> >>> * integrated Neil's power measure-suspend script
> >>> 
> >>> Here is the uImage + link to sources:
> >>> 
> >>> 	http://download.goldelico.com/gta04-kernel/4.3-rc6/
> >>> 
> >>> USB charging is still broken. Anyone with an idea or fix?
> >>> 
> >> well, at least here at least one cause is the high max_current setting
> >> in combination with some not-so-good usb cable.
> > 
> > So does it charge for you?
> > I can neither charge a GTA04 nor an OpenPandora through USB.
> 
> Here is what I see in sysfs:
> 
> root at gta04:~# cat /sys/class/power_supply/twl4030_usb/max_current 
> 100000
> root at gta04:~# cat /sys/class/power_supply/twl4030_usb/mode        
> off [auto] continuous
> root at gta04:~# cat /sys/class/power_supply/twl4030_usb/current_now 
> cat: /sys/class/power_supply/twl4030_usb/current_now: No data available
> root at gta04:~# cat /sys/class/power_supply/twl4030_usb/online      
> 0
> root at gta04:~# cat /sys/class/power_supply/twl4030_usb/status 
> Not charging
> root at gta04:~# cat /sys/class/power_supply/twl4030_usb/voltage_now 
> cat: /sys/class/power_supply/twl4030_usb/voltage_now: No data available
> root at gta04:~# 
> 
> So there is not even a trickle charge with 100 mA because the charger
> does not detect that USB is connected.
> 
> BTW: USB is working since I did ssh into the device over this USB cable...
> 
Hmm, USB starves after some time here. It is not detected on my computer.
About charging. I just did a reboot from my 3.7-wheezy setup into my
4.3-rc6 setup. Even with that: no charging.
Once that evil kernel is booted, even reboots into 3.7. do not
reenable charging. Neither does uboot systest ch. Fascinating...

Regards,
Andreas
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 490 bytes
Desc: not available
URL: <http://lists.goldelico.com/pipermail/gta04-owner/attachments/20151022/519b65d5/attachment.asc>


More information about the Gta04-owner mailing list