[Gta04-owner] [Community] [Announce] Goldelico Replicant Testing Snapshot (2015.06)

Lukas Maerdian luk at slyon.de
Sat Jul 25 23:11:15 CEST 2015


Am 25.07.2015 um 21:46 schrieb Adrien Dorsaz:
> Hello,
> 
> Le vendredi 24 juillet 2015 à 11:51 +0200, Lukas Maerdian a écrit :
>>
>> If you want to have a look though, you can grep for "TinyALSA", i.e.:
>>   adb logcat | grep TinyALSA
> 
> I've tried to use the Android's Voice recorder and I had these logs:
> 
>         ######## Voice Recorder
>         ## Capture "adb logcat | grep -i alsa"
>         D/TinyALSA-Audio Input(   83): audio_hw_open_input_stream(0x42062a68, -2147483644, 0x40f86a14, 0x40f86a00)
>         D/TinyALSA-Audio Mixer(   83): tinyalsa_mixer_get_input_props(0x42062b18)
>         D/TinyALSA-Audio Mixer(   83): tinyalsa_mixer_set_input_state(1)
>         D/TinyALSA-Audio Mixer(   83): Setting TX1 Capture Route to Analog
>         D/TinyALSA-Audio Mixer(   83): Setting TX1 Digital Capture Volume to 12
>         D/TinyALSA-Audio Mixer(   83): Setting Analog Capture Volume to 5
>         D/TinyALSA-Audio Mixer(   83): tinyalsa_mixer_set_device(80000004)
>         D/TinyALSA-Audio Mixer(   83): Setting Analog Left Main Mic Capture Switch to on
>         D/TinyALSA-Audio Input(   83): audio_in_standby(0x420722c0)
>         D/TinyALSA-Audio Input(   83): audio_in_standby(0x420722c0)
>         D/TinyALSA-Audio Input(   83): audio_in_set_parameters(0x420722c0, input_source=1;routing=-2147483644)
>         D/TinyALSA-Audio Output(   83): audio_out_standby(0x42065a28)
>         D/TinyALSA-Audio Input(   83): audio_in_standby(0x420722c0)
>         D/TinyALSA-Audio Input(   83): audio_hw_close_input_stream(0x420722c0)
>         D/TinyALSA-Audio Mixer(   83): tinyalsa_mixer_set_input_state(0)
>         D/TinyALSA-Audio Mixer(   83): Setting Analog Left Main Mic Capture Switch to off
>         D/TinyALSA-Audio Output(   83): audio_out_standby(0x42065a28)
>         
>         ## Playing the just captured sound
>         No log, no issues.
> 
> Although, I've noticed these behavior: the 8 first seconds of the
> capture, I hear a loud Larsen effect and if I speak during this time, it
> seems like nothing was recorded except the Larsen. But after these 8
> seconds, every thing comes back to the normal (no more Larsen) and I can
> record correctly my voice.
> 
> Unfortunately, I had nothing more than these logs during the record and
> nothing appears in logs when the Larsen effect stops (even in the
> dmesg).
> 
> For my build issue, it appears that the first time I've built I've
> forgot to apply the "zconf.h" soft link. I had to "make clean" before
> being able to build correctly the bootimage and replicant.
> 
> Now, I have one last issue with the build : as I build as user,
> everything has the "1000:1000" permissions and so, even with the "tar
> --numeric-owner -pxvf" command I get bad permissions for Android (it
> seems that the Replicant installation script fixes the permission after
> the SDcard creation, I need to check it).

Yes, some permissions are fixed in the mkrootfs.sh script [1], which can
be found in the goldelico/scripts/ folder of your build env.

BR,
  Lukas

[1]
http://git.goldelico.com/?p=gta04-replicant.git;a=blob;f=scripts/mkrootfs.sh;hb=HEAD

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 473 bytes
Desc: OpenPGP digital signature
URL: <http://lists.goldelico.com/pipermail/gta04-owner/attachments/20150725/b8af443d/attachment.asc>


More information about the Gta04-owner mailing list