[Gta04-owner] GTA04 suspend power consumption

Andreas Kemnade andreas at kemnade.info
Tue Dec 22 07:26:59 CET 2015


Hi,
 
> root at letux:~# ./measure-suspend 
> suspending for 300 seconds
> did wake up
> ./measure-suspend: line 63: /sys/class/power_supply/twl4030_usb/mode: No such file or directory
> ./measure-suspend: line 64: /sys/class/power_supply/twl4030_ac/mode: No such file or directory
> 25717 uA over 299 seconds
> root at letux:~# 
> 
> So this means that we are down at
> 
> 	25 mA 
> 
> in suspend with OPTION modem active. With a 4.4-rc5 kernel.
> 
> Of course no USB nor charging.
> 
> Well, the problem is therefore NOT yet solved. But it has been proven that it can be solved.
> By finding the suspend bug in phy-twl4030-usb.ko

That is a nice milestone.
Hmm, If I can remember correctly, it should be 5mA?
So we still have another 20mA to search for.
Has anyone ever seen a combination of our cpu and tps chip which comes down
to such low currents?

Regards,
Andreas
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 490 bytes
Desc: not available
URL: <http://lists.goldelico.com/pipermail/gta04-owner/attachments/20151222/917b24df/attachment.asc>


More information about the Gta04-owner mailing list