[Gta04-owner] QtMoko and Bluetooth

Sebastian Reinhardt snr at lmv-hartmannsdorf.de
Wed Nov 20 13:26:23 CET 2013


On 20.11.2013 11:46, Christ van Willegen wrote:
> Hi all,
>
> I was wondering how this is supposed to work...
>
> I turn on BT and the connect to my car's hands-free set. This shows me
> the phone's name in the screen, and (sometimes) the provider and
> antenna strength.
>
> Next, my phone falls asleep, and the display now shows 'No phone'.
>
> I could attach a USB cable to my in-car charger, but I was wondering
> why this should be necessary. Can't the phone go to sleep and leave
> the BT module enabled, waking up on RING and informing the car cit of
> an incoming call?
>
> I can see the need to turn on the phone when I want to make a call via
> the car kit.
>
> Christ van Willegen
I think there is a more serious problem: voice routing for bluetooth is 
not working, or is it? It is possible to connect a headset/carkit via 
bluetooth, button are working, but the voice/mic sink in alsa config is 
missing. So the "power saving" feature/problem is not the main problem 
in this setup, I think.
I tried it with two different headsets: Nolan N-COM (integrated in 
bicycle helmet) and Sennheiser VMX-200. In both cases the buttons are 
working, but no voice!

I made some investigation about the voice routing to bluetooth:

old wiki:
http://wiki.openmoko.org/wiki/Manually_using_Bluetooth#Bluetooth_Headset_on_Freerunner

Qtmoko:
aah, sorry. There is a old patch in gta02 version. but is not working 
anylonger and I can not find it at moment, but I go on searching......

Arch linux wiki (a little bit older, too):
https://wiki.archlinux.org/index.php/Bluetooth

-- 
Kind regards

Sebastian Reinhardt



More information about the Gta04-owner mailing list