[Gta04-owner] Kernel 3.7 issues on 1 GHz GTA04 boards

Dr. H. Nikolaus Schaller hns at goldelico.com
Fri May 17 17:55:50 CEST 2013


Hi,
we have some 800 MHz and some 1 GHz rated DM3730 CPUs on the boards.

Apparently there are subtle differences between the variants not completely
controlled by the 3.7 kernel.

I have got some reports of problems where it turned out that it is a 1 GHz CPU inside,
which *might* be the issue:

* no connection to the 3G modem (this is on the internal USB)
* no HDQ battery status
* backlight is not turned off (and display becoming white) on wheezy
   system (while it does on squeeze on the same device)
* GPS not responding
* VSIM (GPS antenna amplifier voltage) is 1.8V instead of 2.8 - 3 V

Not all issues are at the same time so it may be clocking/timing problems.

Unfortunately neither Neil nor Radek did/do have a GTA04A4 board with 1 GHz so
that the main developers could not test this yet. And I have not done many tests
and I am not familiar with the 3.7 kernel details. So the same issues are likely to
be in the neil-plus kernel.

The old 2.6.32 kernel was derived from the BeagleBoard XM kernel written by TI and
did support the 1 GHz CPU right from the beginning. Unfortunately (or fortunately?)
not all TI code did find its way into the mainline kernel.

So if you think you have problems with a 3.x kernel, please check which CPU version
you have. It is either reported by hw-test or simpler by looking into the factory test
data by typing in the board serial number: http://www.gta04.org/serial.php

If you experience such problems where you think they may be related to the kernel,
please report so that the specialists knwo about and can dig into a solution.

Thanks,
Nikolaus



More information about the Gta04-owner mailing list