[Gta04-owner] Android 3.0 kernel for GTA04

Alexander Rumyantsev ran at mail.wplus.net
Thu May 9 08:14:57 CEST 2013


Hello

1) I would like to support Paul in his request. The problem discussed some times,
but replicant team did not get any support on this way. 
My understanding a situation with Android/Replicant kernel is same as Paul has - we have not
stable kernel. It is some kernel version, which recommended to different Android version:
2.6.35 - Gingerbread, 3.0.8 - ICS . So it is not good to follow latest version kernel 
from Android point of view as you suggest. ( However Denis is going this way now ).
At moment I am trying to find which features from latest kernel versions is it possible to
use with current used, Paul try go get working stage for 3.0 version. 
My opinion that all correction concerning GTA04 should be available not only for latest kernel
version, but for some stable release. Pauls suggestion to work with 3.0 kernel is a good point.
 
> We are still searching a way to have a fully working Android kernel for
> GTA04. I just tried a new combination that may work, if we can solve the
> issues that we are facing with it.
> 
> It is basically a 3.0 kernel from the
> https://android.googlesource.com/kernel/common/+/android-3.0 tree on top
> of which I added gta04 parts. It seems that using the common Android
> tree works best with gta04 than any of the 3.0 omap-specific kernels.
> For instance, there was an IRQ issue with a 3.0 Android kernel that I
> took from omapzoom. That issue does not occur with the common Android
> 3.0 kernel.
> 
> I've started to import gta04 parts on top of the kernel but I would need
> help in order to both add the missing gta04 parts and fix the issues
> encountered with this kernel. I would really need help on this one, I'm
> not going to be able to handle this all by myself and I really think
> having Replicant running on gta04 would be great for the project.
> Moreover, the user-space is already usable and is crazy fast (compared
> to our other Android devices).

2)  Though I prefer to work with Replicant-2.3, which use kernel 3.2 as 
this version has the greatest level of readiness, Pauls approach I consider 
most reasonable and conforming to all necessary requirements. Therefore 
with pleasure I will take part myself and I invite all to render assistance
to the project. 
My five cents: after a short looks (thanks to Denis for a branch in a repository)
I was succeeded to launch Replicant-2.3 with this kernel. Find here a diff-file:
https://docs.google.com/file/d/0B-rRgKAzYyoBakpPRU1wS1MzUU0/edit?usp=sharing
You can compare the result:
https://docs.google.com/file/d/0B-rRgKAzYyoBcHpEUHRUamFOM1k/edit?usp=sharing
with current Replicant-2.3 with 3.2 kernel:
https://docs.google.com/file/d/0B-rRgKAzYyoBcHpEUHRUamFOM1k/edit?usp=sharing

3)I would like to put community attention to only SD-based project. No changes 
in NAND, all work with SD.
All above prepared as SD-based. To prepare working SD:
./replicant_gta04_install.sh system /dev/sdb 
into restored directory. ( change /dev/sdb to your device ).
I hope that latest uBoot ( http://lists.goldelico.com/pipermail/gta04-owner/2013-March/004188.html )
installed in NAND - it is typical for current Qt-system or HW-validation system. 
Boot from SD1 using new uBoot.

Alexandre
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: This is a digitally signed message part
URL: <http://lists.goldelico.com/pipermail/gta04-owner/attachments/20130509/11e1cac6/attachment.bin>


More information about the Gta04-owner mailing list