[Gta04-owner] fm-tuner - was Re: hw routing audio patch removed in 3.7?

Dr. H. Nikolaus Schaller hns at goldelico.com
Sat Jun 8 18:10:53 CEST 2013


Am 08.06.2013 um 18:00 schrieb Benjamin Deering:

> 
>> Hmm, so put the conflicting McBSP into the platform data and calling the
>> tristate function instead of the pinmux thing? That is no twl4030
>> specific code, so somehow it still feels a bit strange to have it there.
>> But using a tristate function is a step forward.
>> 
>> Greetings
>> Andreas Kemnade
> Is the change needed to enable audio from the FM tuner chip similar to the gsm HW routing issue?

No, there is no direct connection ("hardware routing") between the FM chip and the Audio Codec (TPS65950) so that it needs CPU support.

> 
> I have your userspace hack from here: 
> http://misc.andi.de1.cc/si4721.c, 
Oh that is cool!
> it shows that it is finding a station, but nothing I can do in the mixer gets audio.
What it needs is some arecord | aplayer pipeline through the CPU similar to the /root/dial [1] script but reading a different McBSP / ALSA "sound card".

But even then it is not clear if that works. AFAIK nobody was able yet to test this digital sound interface. So there may be driver issues, configuration issues (e.g. PCM format and clock rate) and I even can't exclude hardware issues (someone told me a while ago that the interface resistors may be wrongly choosen although they match some recommendation from Silicon Labs).

Nikolaus

[1] http://git.goldelico.com/?p=gta04-rootfs.git;a=blob;f=debian/config/root/dial;h=c12648cc9b1ab91b657d764a3884e1fbabc38a0c;hb=HEAD

64      arecord -fS16_LE -r8000 | aplay -Dhw:1,0 &      # microphone -> modem
65      arecord -Dhw:1,0 -fS16_LE -r8000 | aplay        # modem -> earpiece, speaker, headset
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.goldelico.com/pipermail/gta04-owner/attachments/20130608/590facc0/attachment-0001.html>


More information about the Gta04-owner mailing list