[Gta04-owner] Non-free drivers for powervr available ?

Adrien Dorsaz adrien at adorsaz.ch
Mon Jul 15 23:07:59 CEST 2013


Hello,

> > Please share experiences.
> 
> I've tried it once, and it worked fine – on the framebuffer.
> To get Gnome 3 to work (which would be awesome! – especially for the
> Letux 7004 tablet) you have to tinker with the Xorg driver/version, I
> guess, which might be some more work.
> 
> Please share any experiences you have!
> 
> BR,
>   Lukas

Well, I've tried to install gnome-session-fallback and gnome-session
from Debian Wheezy (so Gnome 3.4) upon the hardware validation rootfs
with kernel 3.7 on uSD.

I had to remove the automatic X launch from the /etc/inittab file (end
of the file). Then I've run as this :

$ X &
$ gnome-session[-fallback] # I've used the gnome-session tools because
it permits to have good screen resolution and configuration...

IIRC, to get on screen keyboard I've installed the following packages
(at least the 2 first) :
caribou gir1.2-atk-1.0 gir1.2-caribou-1.0

I had the following results :

      * You can run gnome-session-fallback (so gnome-panel) without any
        issue except that the caribou keyboard won't work because of the
        lake of the 3D hardware.
      * If you follow the hints given by Nikolaus before, you can
        install the 3D hardware driver with experimental package and so
        you can use the onscreen keyboard with gnome-panel
      * I wasn't able to run gnome-session, so gnome-shell (I don't
        remember warning/errors messages, but the issue wasn't obvious)

Then I've upgraded to unstable/experimental Debian to try Gnome 3.8
(that's why I didn't retrieve the 3.4 error messages) and I wasn't able
to run it, because the gnome scripts didn't find any 3D hardware
acceleration.

I was surprised by this result, because, as I was able to use caribou
with gnome 3.4, I was sure to have hardware acceleration. Although I
don't know what the test script exactly tests, so I think it isn't
enough to have powervr acceleration to use gnome 3.8 (gnome shell or
classic mode).

I don't know if we can bypass this acceleration test. If you know, I can
still try it, my uSD has still Debian experimental on it.

Sorry for the lake of precision,

Adrien
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: This is a digitally signed message part
URL: <http://lists.goldelico.com/pipermail/gta04-owner/attachments/20130715/0b2490e3/attachment.bin>


More information about the Gta04-owner mailing list