[Gta04-owner] Replicant GTA04 : suspend bug

Alexander Rumyantsev ran at mail.wplus.net
Sun Jan 27 17:37:52 CET 2013


Hello.

> > That's really good but as noticed on the wiki, there's an issue with the
> > suspend. I've noticed some strange behavior : 
> >      1. plug your GTA04 on your computer, set it to debug mode
> >      2. check the option to not suspend (this option is available in the
> >         notification bar when you click on the debug notification)
> >      3. click on power button in the home to suspend
> >      4. click again on power and you can resume without issue
> 
> Yes, in some cases such as this one, suspend/resume works. If you try
> playing music and then suspend (even if not connected via USB), resume
> will always work too.
> 
> Android seems to use standard Linux suspend/resume process, so I guess
> the problem is in the kernel. 

Trying to investigate this problem I notice this patch
https://github.com/radekp/linux-2.6/commit/1dcf9f5f6493e5278edb5eadb453c8b9c8ee6dc2
After testing with Replicant-2.3 I found that I have not suspend/resume problem. So
1) patch may be a temporary solution
2) Radek or Nail - please, could you give more detail what was a reason you implement
this patch and what was next steps.

> I will need to investigate that a bit more
> when porting to Replicant 4.0.
> 
> > I've also noticed that without point 2, you can suspend and resume, but
> > only once.
> 
> Thanks for the report!

Alexandre
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: This is a digitally signed message part
URL: <http://lists.goldelico.com/pipermail/gta04-owner/attachments/20130127/b540bd7c/attachment.bin>


More information about the Gta04-owner mailing list