[Gta04-owner] Build script for GTA04/wheezy/armhf

Radek Polak psonek2 at seznam.cz
Thu Feb 28 16:02:30 CET 2013


On Thursday, February 28, 2013 02:52:21 PM Radek Polak wrote:

> On Thursday, February 28, 2013 12:59:30 AM Neil Jerram wrote:
> > Yes, that sounds very nice.  Do you think that the two qbuild.pro
> > changes will be OK for a GTA02/armel build as well as for GTA04/armhf?
> 
> I think they will be ok. Btw i am trying to install the chroot now, but i
> am getting this error:
> 
> Setting up emdebian-archive-keyring (2.0.3) ...
> OK
> Get:1 http://www.emdebian.org unstable InRelease [5059 B]
> Get:2 http://www.emdebian.org unstable/main amd64 Packages [186 kB]
> Hit http://cdn.debian.net wheezy InRelease
> Ign http://www.emdebian.org unstable/main Translation-en
> Get:3 http://cdn.debian.net wheezy/main amd64 Packages/DiffIndex [7876 B]
> Get:4 http://cdn.debian.net wheezy/contrib amd64 Packages [42.2 kB]
> Get:5 http://cdn.debian.net wheezy/non-free amd64 Packages [81.1 kB]
> Get:6 http://cdn.debian.net wheezy/contrib Translation-en [35.0 kB]
> Get:7 http://cdn.debian.net wheezy/main Translation-en/DiffIndex [7876 B]
> Get:8 http://cdn.debian.net wheezy/non-free Translation-en [66.3 kB]
> Fetched 431 kB in 3s (133 kB/s)
> Reading package lists... Done
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
> 
> The following packages have unmet dependencies:
>  g++-4.6-arm-linux-gnueabihf : Depends: libstdc++6-4.6-dev-armhf-cross (=
> 4.6.3-14) but it is not going to be installed
> E: Unable to correct problems, you have held broken packages.
> 
> The chroot is installed ok, but the cross compiler is missing because of
> the error. I didnt have much time to dig in it, but maybe you have idea?

I have figured it out :) The problem is this line:

	apt-get install g++-4.6-arm-linux-gnueabihf

if i bump version to 4.7 it installs fine. Should i commit it together with 
qmake.conf using 4.7 gcc change? Or is there better fix?

Regards

Radek
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.goldelico.com/pipermail/gta04-owner/attachments/20130228/ef0537da/attachment.html>


More information about the Gta04-owner mailing list