[Gta04-owner] Modem closes serial line after active calls (sometimes)

Simon Busch morphis at gravedo.de
Thu May 3 14:41:08 CEST 2012


On 03.05.2012 13:16, Neil Jerram wrote:
> Simon Busch <morphis at gravedo.de> writes:
> 
>> On 29.04.2012 15:56, Radek Polak wrote:
>>> On Saturday 28 April 2012 12:44:10 Simon Busch wrote:
>>>
>>>> As far as I got the details from that thread there is no clean solution
>>>> for the disconnecting modem just a workaround as Radek implemented it
>>>> for qtmoko, right?
>>>
>>> Yup, i found no clean solution. Currently i switch to 2G on modem 
>>> initialization - this seems to help + after 30s of unsuccessful reads i 
>>> restart whole QtMoko + some other hacks:
>>
>> Yeah, 2G seems to solve the problem. I tried with limiting the radio
>> access to 2G only and never got a disconnect from the modem.
>>
>> Disabling 3G generally for the GTA04 is nothing we really want. So I am
>> thinking about just limiting the radio access to 2G when dealing with
>> calls. When a call is incoming or outgoing we have to switch the radio
>> access to 2G and switch it back to ANY when we're done with call
>> handling. Let's see if this works not just in theory ...
> 
> Nice idea!
> 
> In parallel, though, I believe Nikolaus was going to look into the
> possibilities for modem firmware upgrade.  Nikolaus, is there any news
> on that?

Both sounds a lot bettern than doing such ugly workarounds in userspace.
Can someone investigate the kernel approach Radek mentioned?

Upgrading the firmware would another nice way but should only be done
when it's safe and doesn't break the modem.

regards,
Simon

-- 
Simon Busch - http://mm.gravedo.de/blog/


More information about the Gta04-owner mailing list