[Gta04-owner] NAND behavior while flashing qtmoko

Dr. H. Nikolaus Schaller hns at goldelico.com
Mon Mar 26 11:14:17 CEST 2012


Am 26.03.2012 um 10:53 schrieb Andreas Kemnade:

> Hi,
> 
> On Mon, 26 Mar 2012 09:20:01 +0200
> Radek Polak <psonek2 at seznam.cz> wrote:
> 
>> On Sunday 25 March 2012 17:12:21 Michele Brocco wrote:
>> 
>>> just want to report some experiences while flashing qtmoko to NAND:
>>> 
>>> - first, why has the qtmoko kernel a hardcoded path for the rootfs?
>>> Why doesn't it get the parameters from u-boot?
>> 
>> It's quite hard to troubleshoot problems if everyone used different boot 
>> params. I am using the same boot cmdline as Neil Brown's kernel. I am not 
>> kernel developer and i believe that he has got them right.
>> 
> But why are you not using
> CONFIG_CMDLINE_EXTEND=y
> 
> Then you can choose to provide only the rootfs via uboot and not
> other complicated stuff. I do not know why it makes troubleshoot
> problems significant harder if the user can choose the rootfs partition.
> On desktops that does not cause problems. On GTA02 you could choose
> your rootfs from the bootloader. 
> But I also doubt that the commandline is a good place for so many configurations
> for regular use.

Yes, there should be only two configs choosen from the bootloader:
* rootfs location (but not rootfs type - if possible)
* display (so that we may boot on TVout)

Then it is not necessary to change anything in u-boot (or bootargs)
for different distros.

> With that setting we can start about thinking about a mechanism to
> configure the boot loader from distro scripts.

That is something I would prefer to avoid. The reason is that you
can break so much very easily and then you need access to the
U-Boot console to restore it. Only a small percentage of users has
the RS232 cable and the knowledge to do that.

And each time someone wants to change the distro, this changes
the boot loader. This does not appear to be the right approach.

So I would prefer to have a single rock-solid bootloader setup
without the need for configuration options (unless necessary).

If the kernel were better in detecting the file system type in NAND, I think
everything would be solved (it would just get NAND or SD as rootfs location).

Or maybe it can be solved with Radek's proposal of an initramfs.

Nikolaus



More information about the Gta04-owner mailing list