[Gta04-owner] QtMoko-v40: USB network and SIM card works only sometimes, Zombies

rf0 nobodyo at web.de
Thu Mar 22 23:52:20 CET 2012


Hi,

> > The updating via apt/aptitude worked, but with an error message:
> > 
> >   Errors were encountered while processing:
> >    qtmoko-gta04
> >   E: Sub-process /usr/bin/dpkg returned an error code (1)
> >   A package failed to install.  Trying to recover:
> >   Setting up qtmoko-gta04 (41-1) ...
> >   insserv: Service bluetooth has to be enabled to start service qtmoko
> >   insserv: exiting now!
> >   update-rc.d: error: insserv rejected the script header
> >   dpkg: error processing qtmoko-gta04 (--configure):
> >    subprocess installed post-installation script returned error exit status
> > 1 Errors were encountered while processing:
> >    qtmoko-gta04
> > 
> > Can this be the reason why USB network fails?
> 
> I dont think so. Please check lsmod if you can see "g_ether" module and 
> ifconfig if you can see "usb0" interface. 

Yes, i can see them, but only afer logging in via USB and ssh. I can not
see what happens when USB network fails.
Yesterday i had the bug that all USB connections on my PC had only full
speed (12 Mbit/s) and that USB0 could be seen but not used:

# ifconfig usb0 192.168.0.200 netmask 255.255.255.0; ping 192.168.0.202
PING 192.168.0.202 (192.168.0.202) 56(84) bytes of data.
>From 192.168.0.200 icmp_seq=1 Destination Host Unreachable

With my notebook i could see the same error, but today it works.


> The problem with update is that qtmoko depends on bluetooth, but i had to 
> temporary disable bluetooth and update-rc.d now complains about it. Now that 
> bluetooth works i can try to enable it again, but this can be in v43 (v42 is 
> now building).

When will v43 be available?

And will it have a RTC which can be used?
I tried setting date and time, but via the GUI it's not possible and
via shell it also does not work:

>hwclock --debug --rtc=/dev/rtc0 --systohc
hwclock from util-linux-ng 2.17.2
hwclock: Open of /dev/rtc0 failed, errno=16: Device or resource busy.
No usable clock interface found.
Cannot access the Hardware Clock via any known method.

Regards,

Rolf




More information about the Gta04-owner mailing list