[Gta04-owner] QtMoko-v40: USB network and SIM card works only sometimes, Zombies

Radek Polak psonek2 at seznam.cz
Wed Mar 21 08:31:26 CET 2012


On Tuesday 20 March 2012 22:09:31 nobodyO at web.de wrote:

> i'm using QtMoko-v40, but after some instllation (ntpdate aptitude
> apt-file joe etc.) and updating, the USB netwok connection does not
> work: The kernel on the PC or notebook reports:
> 
> [858836.403764] usb 5-2: new full speed USB device number 22 using uhci_hcd
> [858841.990429] hub 5-0:1.0: unable to enumerate USB device on port 2

This sounds like the real issue.

> I tried rebooting of the GTA04 several times, but no change.
> The updating via apt/aptitude worked, but with an error message:
> 
>   Errors were encountered while processing:
>    qtmoko-gta04
>   E: Sub-process /usr/bin/dpkg returned an error code (1)
>   A package failed to install.  Trying to recover:
>   Setting up qtmoko-gta04 (41-1) ...
>   insserv: Service bluetooth has to be enabled to start service qtmoko
>   insserv: exiting now!
>   update-rc.d: error: insserv rejected the script header
>   dpkg: error processing qtmoko-gta04 (--configure):
>    subprocess installed post-installation script returned error exit status
> 1 Errors were encountered while processing:
>    qtmoko-gta04
> 
> Can this be the reason why USB network fails?

I dont think so. Please check lsmod if you can see "g_ether" module and 
ifconfig if you can see "usb0" interface. BTW usb networking is configured via 
standard /etc/network/interfaces way.

The problem with update is that qtmoko depends on bluetooth, but i had to 
temporary disable bluetooth and update-rc.d now complains about it. Now that 
bluetooth works i can try to enable it again, but this can be in v43 (v42 is 
now building).

> Another problem was that no SIM Card was found, although i tried four
> different cards, all two times. The error message was "No modem".
> 
> So i took another (slower) SD card, also 8 GB capacity, made a new
> installation and the problems vanished: The SIM card was found and 6
> new messages arrived! And also USB network works.
> I could also add swap via
> 
>   swapon /dev/mmcblk0p3
> 
> Can the sort of the SD card be the reason why no SIM card was found?

Interesting... I have so far tried 16GB class 2 and 16GB class 10 cards and 
both are working perfectly. But it can be that the phone does not like the 
card and strange things are happening... 

> Another point are Zombies, because there are seven Zombies:
> 
> S   PID COMMAND          PPID
> Z     9 swapp <defunct>     1
> Z    17 swapp <defunct>     1
> Z    38 swapp <defunct>     1
> Z    39 swapp <defunct>     1
> Z    40 swapp <defunct>     1
> Z    42 swapp <defunct>     1
> Z    46 swapp <defunct>     1
> 
> How can i get rid of them?

Not much ideas here. One thing that could help. Default qtmoko installation 
expects the swap to be on /dev/mmcblk0p4. We are expecting /dev/mmcblk0p3 to 
be fat partition with media. So maybe try this partitioning or edit /etc/fstab 
to your layout.

Regards

Radek


More information about the Gta04-owner mailing list