[Gta04-owner] QtMoko-v40: USB network and SIM card works only sometimes, Zombies

nobodyO at web.de nobodyO at web.de
Tue Mar 20 22:09:31 CET 2012


Hi,

i'm using QtMoko-v40, but after some instllation (ntpdate aptitude
apt-file joe etc.) and updating, the USB netwok connection does not
work: The kernel on the PC or notebook reports:

[858836.403764] usb 5-2: new full speed USB device number 22 using uhci_hcd
[858841.990429] hub 5-0:1.0: unable to enumerate USB device on port 2

I tried rebooting of the GTA04 several times, but no change.
The updating via apt/aptitude worked, but with an error message:

  Errors were encountered while processing:
   qtmoko-gta04
  E: Sub-process /usr/bin/dpkg returned an error code (1)
  A package failed to install.  Trying to recover:
  Setting up qtmoko-gta04 (41-1) ...
  insserv: Service bluetooth has to be enabled to start service qtmoko
  insserv: exiting now!
  update-rc.d: error: insserv rejected the script header
  dpkg: error processing qtmoko-gta04 (--configure):
   subprocess installed post-installation script returned error exit status 1
  Errors were encountered while processing:
   qtmoko-gta04

Can this be the reason why USB network fails?

Another problem was that no SIM Card was found, although i tried four
different cards, all two times. The error message was "No modem".

So i took another (slower) SD card, also 8 GB capacity, made a new
installation and the problems vanished: The SIM card was found and 6
new messages arrived! And also USB network works.
I could also add swap via

  swapon /dev/mmcblk0p3

Can the sort of the SD card be the reason why no SIM card was found?

Another point are Zombies, because there are seven Zombies:

S   PID COMMAND          PPID
Z     9 swapp <defunct>     1
Z    17 swapp <defunct>     1
Z    38 swapp <defunct>     1
Z    39 swapp <defunct>     1
Z    40 swapp <defunct>     1
Z    42 swapp <defunct>     1
Z    46 swapp <defunct>     1

How can i get rid of them?

Best regards,

Rolf


More information about the Gta04-owner mailing list