[Gta04-owner] Some remarks on qtmoko v41

Sven Dyroff S.Dyroff at phytec.de
Mon Mar 19 12:28:16 CET 2012


Hello,

I want to tell you about the following experiences I made in the meanwhile 
with qtmoko v41. I did a reformat of both file systems FAT and EXT3 and 
used the latest files in order not to mess up with some old stuff. For now 
I haven't installed ofono, but my SIM is in with activated PIN.


1.) Booting
I't not predictable what will happen after inserting the battery. The 
currently encountered possibilities are:

a) Rarely: Phone hangs at once with a constantly green shining power 
button and black display.

b) Sometimes: Does what it should, namely booting up to the screen where I 
can enter my PIN.

c) Frequently: Booting up to the qtmoko-screen without asking me for my 
PIN, then hangs there (not any reaction on touch). I need to press the 
power button, then ...

c1) ... I can touch the green return-arrow and get the qtmoko-screen 
again, which is usable, now.

c2) ... I can touch the green return-arrow and get the dialog to enter my 
PIN, but with message "please wait" forever and without unlock-icon. In 
this case I need to restart the phone again in order to see, which one of 
the described possibilities it will choose for me, now. Thus in some rare 
cases I already had to boot the phone thrice.


2.) Power management

If I followed this mailing list right, it was mentioned that poweroff 
should now go down to about 100 µA for RTC. I cannot confirm this. It's 
the same as before: When I load the battery to 100% full, then poweroff 
the phone for 12 hours and then poweron it again, battery is then less 
than 70% full. I tried two cases, both with the same result:

a) Loading the battery up to 100%, then powering down the phone, then 
removing the USB cable.
b) Loading the battery up to 100%, then removing the USB cable, then 
waiting for about one minute, then powering down the phone.

If the problem cannot be found, I suggest the following approach in order 
to get it finally fixed:

a) GD produces an GTA04 board, mainly only populated with PMIC, OMAP + POP 
and stuff for serial port. This serial port will be connected to an PC 
that is accessible by community people like NeilBrown for making tests. 
This device will be supplied by an remote controllable power supply 
instead of a battery, so that the remote user can switch it on and off and 
get the measurements about power consumption. Power button should also be 
remote controllable in order to be able to make resets.

b) After having managed that this device will suspend as well as power 
down to the expected power consumption, GD populates the stuff for USB to 
that board. Then the device will be reconnected to the PC, this time with 
a battery put in. Remote controllable power supply will now be connected 
to USB, instead. An additional remote controllable ammeter delivers 
information about battery draining during suspend and power off.

c) After having managed that this device will suspend as well as power 
down to the expected power consumption, GD populates one chip after the 
other and remote user check their power consumption until the GTA04 is 
fully populated again and all problems with power consumption have 
ultimately been fixed.


3.) GPS

I meanwhile managed to get my first fix. But reception seems to be very 
weak. I need free glance to the sky in all directions, then it takes about 
2 minutes for first fix with internal antenna. When being in a forest, I 
had no chance, although the trees currently don't have greenery and so 
through them I could see the sky without problems. At home even with 
external antenna placed onto the window ledge, still no chance.

I have a question about NeronGPS. I found the following nice 
documentation: http://tvuillaume.free.fr/NeronGPS/users_guide.htm  But 
what do the "+" and the "-" mean? In qtmoko v41 they're now no more within 
circles, but placed within the upper left and right corner. But what do 
they mean? Can anyone please explain?

Best regards
   Sven


 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.goldelico.com/pipermail/gta04-owner/attachments/20120319/856d8791/attachment.html>


More information about the Gta04-owner mailing list