[Gta04-owner] QtMoko v41

Michele Brocco ssj2micvm at gmail.com
Sun Mar 11 19:36:03 CET 2012


Hi,

I tested the NAND version and it works! My feeling is also that it is
a bit faster. I am just trying to launch qtmoko from SD now through
boot menu but it looks for an img1.rbg16z. And it is not able to find
or load any. I tried to cp another rbg16z file as img1.rbgz16z but it
still says:

** Unable to read "img2.rgb16" from mmc 0:1 **
reading img2.rgb16z
MMC: block number 0x1000090d exceeds max(0x762000)
MMC: block number 0x80040972 exceeds max(0x762000)
MMC: block number 0x1000865 exceeds max(0x762000)

** Unable to read "img2.rgb16z" from mmc 0:1 **
NAND read: device 0 offset 0x1d0000, size 0x40000
 262144 bytes read: OK
Error: Bad gzipped data

When I do not start it from boot menu the sd version is loaded but the
kernel loaded is not the one from the SD card is it seems.

Regards and thanks for your work!

Michele

On 3/11/12, Dr. H. Nikolaus Schaller <hns at goldelico.com> wrote:
> Hi Radek,
> great work!
>
> I tried to test it but I get a kernel image CRC error (at least with the
> version in /boot/uImage in the .tgz).
>
> Can you please cross-check?
>
> BR,
> Nikolaus
>
>
>
> Am 10.03.2012 um 22:42 schrieb Radek Polak:
>
>> Hi,
>> QtMoko v41 for your Phoenux is now ready for download [1].
>>
>> List of changes since v40:
>>
>>  * gsm-voice-routing has highest -20 priority
>>  * gsm-voice-routing gained led indicators
>>  * gsm-voice-routing walkie talkie algorithm was improved
>>  * Disabled UMTS on GTA04 to workaround disconnect problem
>>  * Low level modem LED indicators
>>  * Added support for oFono telephony backend
>>  * NAND images
>>  * Wifi is manually turned on when running from devtmpfs
>>  * Removed udev from init again (using devtmps for fast boot)
>>  * GTA04 kernel is built with nodebug options
>>  * RED led is turned off when QtMoko starts
>>  * Build without unnecessary tools (Yann Dirson)
>>  * Disable forced Qt rebuilds (Yann Dirson)
>>  * NeronGPS compiles on 64bit (Yann Dirson)
>>  * Fixes in translations (Yann Dirson)
>>  * Newer v4l headers (Yann Dirson)
>>  * fixed black screen in settings for locked mode
>>  * /media/card is now FAT on /dev/mmcblk0p3
>>  * better description for ringtones settings icon
>>
>> The main work was still on telephony, because it's not yet perfect.
>>
>> I am now using walkie talkie echo reduction. While you are
>> speaking/listening
>> the playback/recording is now completely suppressed - so theoretically
>> there
>> should be no echo at all.
>>
>> The voice routing program has now diagnostics on AUX led. When the program
>>
>> starts it starts slow blinking RED/GREEN until it successfully reads from
>> UMTS
>> sound card. Then it signals RED when walkie talkie algorithm thinks that
>> you
>> are speaking and GREEN when listening.
>>
>> Similar diagnostics is added to modem drivers (for both oFono and
>> QtMoko's).
>> When the modem notifies new call it starts blinking GREEN on POWER led.
>> The
>> blinking works also in suspend and stops when you check missed calls.
>>
>> I was trying to address the problem when modem disconnects on USB [2].
>> Previous fix that was trying to reopen modem tty after few seconds did not
>> work
>> for some reason. I can see that it opens the tty (and also lsof shows it's
>>
>> open), but there were no data coming. So i tried my theory that it
>> disconnects
>> only on UMTS. Now i am sending AT_OPSYS=0,2 on modem init. It would be
>> nice if
>> you could try it and report if you still see modem usb disconnects. If
>> this
>> wont work we need to find another way how to fix this.
>>
>> Nikolaus: do you have any info how modem firmware upgrading works? Is any
>> special hardware required?
>
> I am still working on clear answers.
>
>>
>> Since this release you can use oFono for telephony. It was done in less
>> then 9
>> days. So if you don't like funky Qtopia AT commands you can use oFono ;-)
>> or
>> FSO. All of them are now supported. To use ofono you need to do:
>>
>> 	update-rc.d udev defaults
>> 	apt-get update
>> 	apt-get install ofono
>>
>> Now edit /opt/qtmoko/qpe.env and change QTOPIA_PHONE=oFono
>> You can also set it to Fso or anytime back to AT (it's case sensitive).
>> Btw
>> oFono can be now used only for calls. I havent managed to get SMS working
>> yet.
>>
>> You can now also quite easily install QtMoko to NAND:
>>
>> 1/ boot from SD card
>> 2/ download qtmoko-debian-gta04-v41.jffs2 and uImage-for-jffs2-v41.bin
>> 3/ apt-get install mtd-utils
>> 4/ flash it to NAND:
>>
>> 	flash_eraseall /dev/mtd3
>> 	nandwrite -p /dev/mtd3 uImage-for-jffs2-v41.bin
>>
>> 	flash_eraseall /dev/mtd4
>> 	nandwrite -p /dev/mtd4 qtmoko-debian-gta04-v41.jffs2
>>
>> For me NAND is much much faster then SD card. It boots in 40s without any
>> optimizations. Even telephony is lightning fast compared to SD - taking
>> and
>> hanging calls is immediate. It can be because i have class 2 SD card with
>> big
>> rootfs now...
>>
>> Last thing is updated kernel (latest NeilBrown's). It boots faster, wakes
>> in
>> 1s and is generally much faster.
>>
>> It would be nice if we could make telephony rock stable. I am now using
>> GTA04
>> for about month as my main phone. It's usable, but far from perfect. The
>> main
>> problem was/is? the USB disconnects - i sometimes get to the state where i
>>
>> cant dial/receive call and need reboot.
>>
>> So enjoy and report bugs or success.
>>
>> Regards
>>
>> Radek
>>
>> [1] http://sourceforge.net/projects/qtmoko/files/GTA04/
>> [2]
>> http://lists.goldelico.com/pipermail/gta04-owner/2012-February/001563.html
>> _______________________________________________
>> Gta04-owner mailing list
>> Gta04-owner at goldelico.com
>> http://lists.goldelico.com/mailman/listinfo/gta04-owner
>
> _______________________________________________
> Gta04-owner mailing list
> Gta04-owner at goldelico.com
> http://lists.goldelico.com/mailman/listinfo/gta04-owner
>


More information about the Gta04-owner mailing list