[Gta04-owner] Modem is not reset when GTA04 is powered off

Dr. H. Nikolaus Schaller hns at goldelico.com
Mon Mar 5 20:33:24 CET 2012


Hi Neil,

Am 05.03.2012 um 20:11 schrieb Neil Jerram:

> While testing sending DTMF tones a few days ago, I discovered that the
> modem isn't reset when GTA04 is powered off.  It appears that the
> battery has to be taken out.

> 
> To be precise,
> 
> - I called my other mobile phone, as part of testing DTMF tone sending
> 
> - I didn't properly notice or check whether that call had terminated,
>  but I assumed that it would be next time I rebooted
> 
> - then I got distracted by something else, which involved rebooting the
>  phone, several times over a 2-3 hour period
> 
> - at the end of the evening, I powered off and pulled out the battery,
>  and _then_ the screen of my other phone came on and said "Call Ended".
> 
> So the call had stayed up, from the network's point of view, for the
> whole evening, even through several GTA04 reboots.
> 
> Should "poweroff" somehow reset the modem?  Other thoughts?

This is a known (severe) bug of the GTA04A3 (Early Adopter) boards.

It has been fixed in the GTA04A4 board.

Unfortunately it is impossible to apply the fix to the old boards
without destroying (before replacing) the UMTS module.

A software solution could be that e.g. QtMoko or SHR checks after
starting the gsm daemon if calls are still running and applies
a precautionary AT+CHUP. This would not harm booting a A4 board.

Nikolaus


More information about the Gta04-owner mailing list