[Gta04-owner] Beta Tester's Report on SHR

Lukas Märdian lukasmaerdian at googlemail.com
Thu Mar 1 11:21:37 CET 2012


On 01.03.2012 10:49, Martin Jansa wrote:
> On Thu, Mar 01, 2012 at 09:50:44AM +0100, Sven Dyroff wrote:
>> Hello,
>>
>> I couldn't resist to try out SHR, now. I used the version whose link has 
>> been posted in this list some days ago.
> 
> and that was?
> 
> There are newer versions too:
> http://www.shr-project.org/trac/wiki/StagingTests
> 

I guess he used my GTA04 Install Guide:
http://trac.shr-project.org/trac/wiki/Devices/GTA04/InstallGuide

There is also a link to the latest staging image, with a warning that
it's for testers only... I don't know if he used the staging image for
his beta-test.

>> Starting the phone
>> After booting the first time - which took very very long time - SHR asked 
>> lots of questions where it wanted to have text being entered. But where on 
>> earth can I get the keyboard displayed for that? I couldn't find one, so I 
>> skipped these questions. The text "next" appeared at the bottom of the 
>> screen, in most cases messed up with other screen content, but at least it 
>> worked.
> 
> That's fixed in newer images see that wiki page.
> 
>> Booting for the second time was very fast, but I didn't get the home 
>> screen with all the icons. There where only some few icons at the top of 
>> the screen. I tried them out and somehow I got the icons back in the end. 
>> But not as expected with the house-icon which I expected to be "home", but 
>> with another that seems to be able to split the screen for some unknown 
>> reason. After touching this icon again and again I got the right screen. 
>> And besides I found the keyboard icon, but I couldn't remember if this has 
>> And what was astonishing: Althoug I removed the battery before the phone 
>> presented the right date and time! With QtMoko after having the battery 
>> removed for some time I always have to enter time and date again.
>> So my astonished questions are: How did SHR managed to get the RTC 
>> supplied without battery? Any why doen't QtMoko manage this?
>>
>> Calls
>> Neither could I make calls nor could I receive calls. That was exactly the 
>> behaviour I expected, because up to this time SHR never had asked me for 
>> my PIN. But where on earth shall I enter it??
>>

The problem here is, that we don't activate GTA04a4's modems yet. We
need to trigger the GPIO from FSO. This isn't integrated yet. So you
would have needed to activate the modem manually. One should probably
add this to the Q/A section of the GTA04 Install Guide.

>> Terminal session
>> Please explain me how I manage that this stubborn keyboard does what I 
>> want? I even wasn't able to enter simplest commands like "ls" or "pwd" 
>> because the keyboard did everything, but not giving me some simple 
>> letters!
> 
> There is button on right side of keyboard to switch keyboard type,
> "Terminal" type works best in terminal :).
>  
>> GPS
>> I only see a blank screen with some zeroes at the bottom and a 2000km 
>> measuring stick above. Even after minutes with an external antenna this 
>> doesn't change. Is there an easy way to find out if the GPS module of my 
>> GTA04 is functioning at all? Remember: QtMoko also didn't give me any GPS 
>> coordinates.
> 
> What app did you use?
> 
>> Internet
>> Of course without PIN no connection. But nice to find one more browser 
>> from which I never heared before: "eve". Is it a way to become famous to 
>> create one's own browser? Is Firefox so much terrible?
> 

Firefox works pretty nice on SHR actually. Just opkg-install firefox.

> SHR is using mostly EFL so using eve is more consistent with rest of UI,
> firefox is available in feed.
>  
>> Mumpty Physics
>> Very funny, indeed. But what is this?
>>
>> Power management
>> No reaction by the battery icon when connecting USB to a power supplying 
>> device. "Settings" / "Power" first says "Loading 4 modules" like many SHR 
>> settings want to load several modules each time you call them, but then I 
>> only get "Charge: N/A%", "Power info: N/A" and "Status: N/A". How do I 
>> manage to load the battery with SHR?
>>
>> Settings
>> Extremely much stuff for a beginner. I resign and ruefully return to 
>> QtMoko. But up to the next version of QtMoko coming, I'll dream that this 
>> upcoming version also will be able to supply the RTC while the battery has 
>> been removed like SHR does...
>>
>> Ethernet Gadget
>> I admit it would have been too easy if the IP would have been the same 
>> like QtMoko has: 192.168.0.202! But what is the right IP? Without a 
>> working keyboard on a phone's terminal session no chance to enter 
>> "ifconfig" in order to inspect it by myself, and I didn't want to open the 
>> case in order to connect a serial cable. At least not yet. For the moment 
>> I still avoid to become too much freaky, because my goal is to be able to 
>> present this phone also to friends that do not much understand from 
>> computing.
> 
> bold text on http://www.shr-project.org/trac/wiki says:
> Beware, if you use new SHR (SHR-CORE) images that IP adresses for USB
> networking changed: Phone: 192.168.7.2 Host: 192.168.7.1
>  
>> Shutting down the phone
>> I press the power button, select "Shutdown", even approve with "Yes" and 
>> get the goodbye message: "Please wait: booting...". Then the phone 
>> switches off. Oh yes, I really want to return to QtMoko, happily!!
>>
>> And I cannot spare you what I nastily thought at this moment: Yes, it was 
>> Micro$oft where I had to click "Start" in order to shutdown an OS. Same 
>> thing, just reversed. That was before I switched to Ubuntu...
> 
> I don't have GTA04 to respond on other questions..
> 

BR,
Lukas

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 490 bytes
Desc: OpenPGP digital signature
URL: <http://lists.goldelico.com/pipermail/gta04-owner/attachments/20120301/6132eedc/attachment.bin>


More information about the Gta04-owner mailing list