[Gta04-owner] booting 3.5-rcX kernel failed

NeilBrown neilb at suse.de
Wed Jun 20 11:00:23 CEST 2012


On Wed, 20 Jun 2012 08:14:53 +0200 Belisko Marek <marek.belisko at gmail.com>
wrote:

> On Wed, Jun 20, 2012 at 2:44 AM, Denis 'GNUtoo' Carikli
> <GNUtoo at no-log.org> wrote:
> > On Wed, 2012-06-20 at 01:18 +0200, Denis 'GNUtoo' Carikli wrote:
> >> On Tue, 2012-06-19 at 22:19 +0100, Belisko Marek wrote:
> >> > On Tue, Jun 19, 2012 at 10:13 PM, Denis 'GNUtoo' Carikli
> >> > <GNUtoo at no-log.org> wrote:
> >> > > On Mon, 2012-06-18 at 22:29 +0100, Belisko Marek wrote:
> >> > >> Enable earlyprintk didn't say anything.
> >> > > how did you enable earlyprintk. it require an argument in cmdline.
> >> > I've added also earlyprintk to kernel cmdline but still nothing.
> >> then try to look what's in the buffer of dmesg like that:
> >> I guess the virtual->physical prefix is 0x8 for omap(to check) but if
> >> so, you could try that:
> >> grep __log_buf System.map
> >> c059f7a0 b __log_buf
> >> remove the starting c and replace it by 0x8(or whatever the prefix is)
> I've found this one: https://lkml.org/lkml/2012/6/17/52 but still
> can't get no console output.
> I verify 3.4 and this one I can boot properly (to avoid my error ;)).
> Any thoughts?

Sorry - my bad.

This patch (which is badly space-damaged, just apply it by hand)
got left out of my git push.

It possibly isn't the right patch, but it will do for now and does fix the
console problem.

NeilBrown



diff --git a/drivers/gpio/gpio-omap.c b/drivers/gpio/gpio-omap.c
index c4ed172..db781f7 100644
--- a/drivers/gpio/gpio-omap.c
+++ b/drivers/gpio/gpio-omap.c
@@ -1124,6 +1124,9 @@ static int __devinit omap_gpio_probe(struct platform_device *pde
 
        platform_set_drvdata(pdev, bank);
 
+       if (bank->get_context_loss_count)
+               bank->context_loss_count =
+                       bank->get_context_loss_count(bank->dev);
        pm_runtime_enable(bank->dev);
        pm_runtime_irq_safe(bank->dev);
        pm_runtime_get_sync(bank->dev);


> >>
> >> then md that address in uboot and press enter many times.
> >> The dmesg should appear.
> > Sorry that won't work.
> > The gta04 lacks a reset button...
> >
> > Denis.
> >
> > _______________________________________________
> > Gta04-owner mailing list
> > Gta04-owner at goldelico.com
> > http://lists.goldelico.com/mailman/listinfo/gta04-owner
> 
> marek
> 

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 828 bytes
Desc: not available
URL: <http://lists.goldelico.com/pipermail/gta04-owner/attachments/20120620/562fb593/attachment.bin>


More information about the Gta04-owner mailing list