[Gta04-owner] QtMoko v38 for GTA04 with suspend and GSM calls

Boudewijn wankelwankel at yahoo.com
Tue Jan 31 23:11:27 CET 2012


On Tuesday 31 January 2012 15:20:23 Radek Polak wrote:
> On Tuesday 31 January 2012 12:01:55 Dr. H. Nikolaus Schaller wrote:
> > while testing some boards with our arecord | aplay scripts I observed
> > that the ringing tone of the phone being called is transmitted after
> > several seconds.
> > 
> > Let me try an explanation:
> > * arecord on the microphone starts immediately filling the pipe
> > * aplay towards the modem does not start before it gets clocked
> > * this is only when the connection is accepted
> > * this may delay up to 5 seconds
> > * arecord on the modem does start at the same moment
> > * and aplay on the phone sees an empty pipe until then
> > 
> > So, the filling level of the pipe
> > microphone -> CPU -> pipe -> CPU -> modem
> > 
> > is up to 5 seconds with sound - before the phone call is
> > established. This includes recording the ringing tone of
> > my landline phone :)
> 
> I think i can confirm it. While i was testing the scripts i ran them
> manually - but always during call and that was ok. But now the scripts are
> automatically launched possibly before the call (but you can start and
> stop them during call which should fix the situation then).
> 
> Also my wife complained that i was answering questions while she was
> already asking another thing ;-)
> 
My wife still has to find out which "tricks" I will put in our conversations 
this year around ;-) 

About the limited-length-pipe: could it be piped through some virtual file 
with "logrotate-properties"? Or would the extra processing only add delay 
while taking buffer away?

Boudewijn


-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 1967 bytes
Desc: not available
URL: <http://lists.goldelico.com/pipermail/gta04-owner/attachments/20120131/a7091586/attachment.bin>


More information about the Gta04-owner mailing list