[Gta04-owner] GTA04A4 starts shipping tomorrow

Dr. H. Nikolaus Schaller hns at goldelico.com
Tue Jan 31 11:53:21 CET 2012


Am 31.01.2012 um 15:30 schrieb Gennady.Kupava:

> Hello, Nikolaus,
> 
> В Пнд, 30/01/2012 в 21:13 +0100, Dr. H. Nikolaus Schaller пишет:
>> 
>> After 3 days of intensive research (incl. this weekend) we did find the root
>> cause: it is the same as it was for the GTA02A5 board [1]. The SD card
>> clock. It is 25 MHz and 25 * 63 = 1575 MHz, i.e. the GPS frequency.
>> 
>> This means that the GTA04 creates some noise which is neglectable
>> in more than 5cm distance with an external antenna, but not for the
>> active GPS antenna built into the case. And some boards and
>> antennas are a little better and others are a little worse so that it
>> results in a basically working, but very unreilable receiver.
>> 
>> The main problem was to find a measurement setup that gave
>> reproducible results so that we could not only compare devices, swap
>> antennas and try different shielding scenarios, but also check the
>> effectiveness of measures against the problem.
>> 
>> Like with the GTA02 there is a hardware and a software fix. The SW fix
>> was to re-enable a feature in the 2.6.32 kernel that we had disabled due
>> to problems with the SDIO driver. It appears that it is not at all necessary
>> to change anything in the 3.2 kernel. So please forget immediately that
>> there is a SW fix :) Because it fixes our unawareness and not a problem...
>> 
>> The real hardware fix is adding a small capacitor like for the GTA02A5.
>> 
>> You may wonder why we did not find it earlier. One aspect is testing time.
>> The more testing you do the more issues you find. But we simply did
>> not have enough GTA04A3 boards to do these tests...
> 
> First of all, really nice to see that open phone reached release state.
> 
> As i were always wondering about SD reading issues in GTA02, which rises
> voltage in driver with reduced clock at beginning, and is not working at

This is a patch in the GTA02 kernel to reduce noise *without* capacitor.
Only GTA02A6 boards have it.

> 25MHz at all. I wonder can it be related to that capacitor? Are GTA04
> users going to experience same speed issues with SD like in GTA02?

No. It works at full speed, even with capacitor.



More information about the Gta04-owner mailing list