[Gta04-owner] Now that 3.2-final is out...

NeilBrown neilb at suse.de
Tue Jan 17 06:41:02 CET 2012


On Mon, 16 Jan 2012 08:37:08 +0100 Radek Polak <psonek2 at seznam.cz> wrote:

> On Sunday 15 January 2012 11:52:16 Neil Jerram wrote:
> 
> > Now, if I open the back cover and remove and replace the battery, the
> > GTA04 boots up normally and fully.  So the problem above is not caused
> > by low battery.
> > 
> > Any thoughts / ideas?  This is quite repeatable, so I could get
> > diagnostics if you tell me how...
> 
> IIRC it was mentioned in some older mails that current 3.2 does not boot after 
> halt command, because something is left initialized. You have to always 
> completely power if off (remove battery), halt and reboot are for now not 
> working.

It is definitely mentioned in

  http://projects.goldelico.com/p/gta04-kernel/page/Mainline-Status/#wikititle_34

Unfortunately it freezes before the serial ports are configured so I don't
see any messages to help narrow it down.

I think it is some problem with interrupts from the PMIC causing problems.
That should be fairly easy to confirm once I try, but I've been distracted by
other interesting things like getting CPUIDLE to work and reduce idle power
usage.

NeilBrown
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 828 bytes
Desc: not available
URL: <http://lists.goldelico.com/pipermail/gta04-owner/attachments/20120117/74937155/attachment.bin>


More information about the Gta04-owner mailing list