[Gta04-owner] Routing UMTS sound

Radek Polak psonek2 at seznam.cz
Mon Jan 2 01:17:08 CET 2012


On Sunday 01 January 2012 09:14:14 NeilBrown wrote:

> I would suggest trying to set up pulseaudio to do the routing.

Yes, pulse audio looks quite nice.

> I've done a bit of exploring and this is where I am at:
> 
> 1/ install dbus and pulseaudio and related packages (pulseaudio-utils,
> dbus-x11).
> 
> 2/ Create a non-root user in group 'audio' and use that as pulseaudio
> doesn't seem to like running as root.
> 
> 3/
>    eval `dbus-launch --auto-syntax`
>    pulseaudio --daemon
> 
> 4/
> 
>   pactl load-module module-loopback   \
>        source=alsa_input.platform-soc-audio.0.analog-stereo  \
>        sink=alsa_output.platform-soc-audio.1.analog-mono \
>        rate=8000
> 
>   pactl load-module module-loopback \
>        source=alsa_input.platform-soc-audio.1.analog-mono \
>        sink=alsa_output.platform-soc-audio.0.analog-stereo \
>        rate=8000
> 
> I'm not at all sure that this actually works, but at least it doesn't fail
> miserably, and seems to be heading in the right direction.

It prints no error but it does nothing. I think your commands are ok, but 
maybe there is some problem with pulse audio and the alsa SOC driver.

I tried it on my PC and after loading loopback module all sounds were routed 
from mic to speakers so that i could hear echo. For some reason this does not 
work on GTA04 - even when i tried to connect the internal soundcard input to 
internal soundcard output.

I have installed pavucontrol to check if there is any sound (btw you can try 
it too and use ssh -X to have GTA04's pavucontrol on your PC). It seems that 
all input and output devices alone work ok - they show sound activity on 
recording and playing (same on gsm calls).

In pavucontrol if you select "Show" and "All streams" you will see the 
loopback stream. On the recording tab it shows sound activity but on the 
playback side there is always silence. But when i play some mp3 with mplayer 
it works ok and shows activity on the playback. So something is with the 
routing.

I have also noticed that parec records from internal sound card just fine, but 
it records nothing from the UMTS.

I have also tried

	parec | paplay --raw

which works ok  but with horrible delay on the internal soundcard. Routing 
sound with parec and paplay beween internal card and UMTS is not working for 
me.

Any ideas?

Regards

Radek



More information about the Gta04-owner mailing list