[Gta04-owner] GTA04 voice routing now working!

Andreas Kemnade andreas at kemnade.info
Wed Feb 8 10:19:01 CET 2012


Hi,

On Tue, 7 Feb 2012 09:59:03 +0100
Radek Polak <psonek2 at seznam.cz> wrote:

> 
> > A gta02 kernel on a gta04?
> 
> Ahh sorry, i pasted wrong url.
> 
> > I tried this one instead:
> > http://qtmoko.sourceforge.net/debian/gta04/linux-image-3.2-qtmoko-gta04_38-
> > 1_armel.deb Of course I need to boot into it with the gpio186 in the right
> > state as this kernel does not export it in contrairy to my one (can send
> > patch for that, if it should be included as an interim solution as long as
> > there is no more intelligent rfkill mechanism looking at usb devices).
> 
> Patch would be nice, i am doing new qtmoko release and it would be nice if it 
> worked on GTA04A04.
> 
> > Same problem.  arecord -D default:CARD=gta04voice -fS16_LE
> > does not work either.
> > arecord -D default:CARD=gta04 -fS16_LE | aplay -D default:CARD=gta04
> > -fS16_LE works ok (it gives echo)
> > 
> > Yes, I also tried it during a call.
> > 
> > AT_ODO=0
> > OK
> > AT_OPCMENABLE=1
> > OK
> > AT_OPCMPROF=0
> > OK
> > ATDxxxxx;
> > OK
> > 
> 
> So you have no sound from umts at all? Even simple
> 
> 	arecord -Dhw:1,0
> 
> or
> 
> 	aplay -Dhw:1,0 /usr/share/sounds/alsa/some.wav
> 
> are not working?
> 
on 2.6.32 it is working but not on 3.2, I guess that should be the other patch
mentioned in the thread. 
arecord -D default:CARD=gta04 | aplay -D default:CARD=gta04voice
and vice versa works there. So at least I know that I can use my gta04 as a phone
with the right software and no hidden production problem which did
not show up in the gta04 tester.


Greetings
Andreas Kemnade

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 197 bytes
Desc: not available
URL: <http://lists.goldelico.com/pipermail/gta04-owner/attachments/20120208/3e96f9cb/attachment.bin>


More information about the Gta04-owner mailing list