[Gta04-owner] GTA04 voice routing now working!

Rene Leitner rene.leitner at gmx.net
Fri Feb 3 23:09:28 CET 2012


Hi Radek,

I have test the programm on debian and I get this error:

p1 (hw:1,0): snd_pcm_hw_params_set_period_size failed: 
retrying in 100 ms

Can you help?

Thanks a lot,
Rene

Am Freitag, den 03.02.2012, 15:02 +0100 schrieb Radek Polak:
> Hi,
> i have worked some more on the voice routing program.
> 
> First it has now git repository here[1]. You can play with it and improve it 
> it. I have chosen LGPL license, but if you need something else please let me 
> know.
> 
> Since last mail i have changed the sequence in loop - it first records from 
> both cards and then plays on both card which is more logical.
> 
> The code now also ignores read errors in umts recording direction - this is 
> normal before call is estabilished. When no such read error occurs it starts 
> the routing loop and ends up on first read error which indicates that call was 
> hung up.
> 
> I have also made the period buffers as small as possible. Now their size is 250 
> frames which gives us at 8000Hz nice 31.25ms long latency. I made a call and 
> got confirmed that everything is ok (no delay, no echo, sound quality ok) and 
> the same success was in received call.
> 
> Next thing to do is to check if we still have echo - i have earpiece volume 
> very low and no echo was noticed, but i think that with higher volume it will 
> be there. But i have in my mind simple echo suppression algorithm...
> 
> So happy calling from your GTA04!
> 
> Radek
> 
> https://github.com/radekp/gta04-gsm-voice-routing
> _______________________________________________
> Gta04-owner mailing list
> Gta04-owner at goldelico.com
> http://lists.goldelico.com/mailman/listinfo/gta04-owner




More information about the Gta04-owner mailing list