[Gta04-owner] linux-image-3.5-qtmoko-gta04 deb not installable

arne anka openmoko at ginguppin.de
Sat Dec 1 19:06:01 CET 2012


hi,

bought a new sd card, partitioned according to last known good boot style  
with /dev/mmcblk0p1 as vfat.
installed squeeze-lxde to p2 and copied uImage to p1.

everything boots ok, but kernel is of course 2.6. but since i'd like to  
play with Sid instead of Squeeze, i need 3.x
so, i tried to install Neill's

linux-image-3.5-qtmoko-gta04

but that fails with:

Unpacking linux-image-3.5-qtmoko-gta04 (from  
.../linux-image-3.5-qtmoko-gta04_48-1_armel.deb) ...
dpkg: error processing  
/var/cache/apt/archives/linux-image-3.5-qtmoko-gta04_48-1_armel.deb  
(--unpack):
  unable to make backup link of `./boot/uImage' before installing new  
version: Operation not permitted
configured to not write apport reports
                                       dpkg-deb: subprocess paste killed by  
signal (Broken pipe)
Errors were encountered while processing:
  /var/cache/apt/archives/linux-image-3.5-qtmoko-gta04_48-1_armel.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

which isn't really surprising, since /boot is p1, which is vfat, which  
does not support links.

question: is this expected/to be neglected (after all, as a workaround i  
can unmount /boot and re-mount afterwards and copy the new kernel  
manually)? or should something be done to fix that?


More information about the Gta04-owner mailing list