[Gta04-owner] QtMoko mic volume

Neil Jerram neil at ossau.homelinux.net
Sat Aug 25 14:44:20 CEST 2012


Radek Polak <psonek2 at seznam.cz> writes:

> On Saturday, August 25, 2012 12:30:50 AM Neil Jerram wrote:
>
>> Anyway, finally I have good news.  After building Radek's
>> v3.2-gta04-qtmoko-v47 kernel - except without Andreas's patch ([1]
>> above) - and also after reverting the corresponding alsa state change in
>> the QtMoko rootfs [2], audio works again in both directions of a phone
>> call.  So I think [1] was what broke audio for GTA04A3; reverting [2] is
>> needed because [1] adds more mixer controls and so changes what is
>> needed in the state files.
>
> If the problem is really the HW sound routing patch, then we need to fix it up. 
> Maybe we can add these new controls only for A4.
>
> Having two sets of alsa states is not a problem - QtMoko already uses different 
> state files for A3 and A4 (earpiece.state / earpiecehw.state).

Hi Andreas,

After looking at your patch more carefully, I see that most of the
change is subject to the new "Voice route" control.  Apart from that,
there's just a change to twl4030_init_chip() that might just be cleanup,
or which might be fine for A3.

Therefore, _maybe_ the only change that A3 needs is for the "Voice
route" control to be "Voice to SoC" instead of "Voice to twl4030".

I'll try that out anyway, but would appreciate your comments if you have
time.

Thanks,
        Neil


More information about the Gta04-owner mailing list